Cydia Error:Database

Discussion in 'Jailbreaks and iOS Hacks' started by fishmd, Nov 15, 2009.

  1. fishmd macrumors 68000

    fishmd

    Joined:
    Jun 18, 2008
    Location:
    Sunny South Florida
    #1
    Problem. As above, all of a sudden whenever I try to use Cydia I get this error. It says, Error: Database Encountered a section with no Package: Header.

    Then when Cydia loads, I have nothing there. The home page loads, but that is it. No packages show, even the ones that are already installed on the phone. Nothing shows under sources either. If I look under "Sections", nothing is there either.

    Don't know what happened. I used Cydia earlier in the day, then later went in to check it again, and nothing was there. I have rebooted the phone to no avail. Also tried to re-install the cydia repo package from my PkgBackup, but nothing is showing still. :(:confused:
     
  2. Cortezbanks macrumors 6502

    Joined:
    Sep 5, 2008
    #2

    I had the same problem, it was from a bad repo. If that's the problem you need to ssh in and remove the bad source in 2 places. It's not too hard
     
  3. fishmd thread starter macrumors 68000

    fishmd

    Joined:
    Jun 18, 2008
    Location:
    Sunny South Florida
    #3
    Hum, very very strange. Now after being gone for a full day, it is working once again. This is without any new changes mind you. I did not add any newer repo recently, so all the repos I have should be fine. I don't know, but now I am getting data again and can see all my packages that were installed etc. Great, I think I may be looking at a restore in the near future. :rolleyes:
     

Share This Page