Cydia Error

Discussion in 'Jailbreaks and iOS Hacks' started by thekarbunkler, Feb 1, 2010.

  1. thekarbunkler macrumors member

    Joined:
    Sep 15, 2009
    #1
    I am getting this error when trying to launch Cydia, "Error: Database Encountered with no Package: header" Does anyone know how to fix this? I hit "Okay" and then the same error message appears. Thanks!
     
  2. tctony macrumors 6502a

    tctony

    Joined:
    Jun 15, 2009
    #2
    I got this error. I thought it was related to something I had just changed (changed a version number of an app so I didn't have to see the update button for it.) I reinstalled Cydia. But now I can't see any of my installed packages..

    There were some problems with Cydia last night. I'd wait it out.
     
  3. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #3
    Is that the complete text of the error message?
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    I had that happen 3 days ago, tried to remove, then re-install, never could get Cydia to see any of my installed packages (PkgBackup didn't see them either).

    After 2 days of trying everything I know and could find, I ended up restoring, then re-JB.

    All is good now.
     
  5. thekarbunkler thread starter macrumors member

    Joined:
    Sep 15, 2009
    #5

    that is exactly what i was dreading! might have to though....
     
  6. tctony macrumors 6502a

    tctony

    Joined:
    Jun 15, 2009
    #6

    I'm feeling way too lazy to restore again, as I've already done it like 3 or 4 times over the last few days (updated from 3.0 to 3.1.2) haha. I'm not sure what to do, because all of my packages are still operating, they just don't show up.
     
  7. basesloaded190 macrumors 68030

    basesloaded190

    Joined:
    Oct 16, 2007
    Location:
    Wisconsin
    #7
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    Yea, that is a well known fix and I tried it several times as well as a plethora of other remedies over the course of my 2 day fight with Cydia.

    No go. I wasn't having any source error indications anyway, but I still tried everything I knew or could find via research.

    All my packages were also working, just not being recognized by Cydia or PkgBackup.
     
  9. Jedi5 macrumors 6502

    Jedi5

    Joined:
    Aug 16, 2009
    Location:
    North Burbs, IL
    #9
    I too have been getting this error message for about 2 weeks now.
    I can't SSH because I never installed it.
    I've read many different opinions on how to fix this error problem and it seems like if you know what you are doing, they should all work.

    Of course key words there are "know what you are doing"... which I don't.

    So if I restore and then JB again, what apps/info will I lose?
    Will I lose any contact info/pics/apps?

    Thanks.
     
  10. basesloaded190 macrumors 68030

    basesloaded190

    Joined:
    Oct 16, 2007
    Location:
    Wisconsin
    #10
    That's really strange. Sucks you had to start all over. I don't know what the deal is but a lot of people seem to be having problems with cydia lately
     
  11. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #11
    You can install OpenSSH thru Cydia. It isn't that hard to use. If you do install OpenSSH, don't forget to change root & mobile passwords.

    Back up all your stuff (apps, contacts, calendar, photos, etc) in iTunes. You will lose your texts.

    Restore, set up as new (be careful with restore if you need to unlock so you don't update your baseband) Choose set up as new (you will lose your settings)

    Re-JB, choose set up as new. When done, sync all your stuff back via iTunes.
     
  12. Jedi5 macrumors 6502

    Jedi5

    Joined:
    Aug 16, 2009
    Location:
    North Burbs, IL
    #12
    With OpenSSh, I meant I can't install now as Cydia won't let me.
    I get the "Cannot Locate Package" message.

    Backing everything else up... OK.

    You lost me here...

    So I restore as new. Will I be asked to upgrade to latest version (3.1 or whatever it is now?), I'm still at 3.0. If so, I can decline the update, right?
    I think I can...

    So now I have my iPhone restored and on to unlock and JB again.

    After restore I want to be able to unlock for JB.
    So what steps do I have to take to assure I don't screw something up?

    Thanks.
     
  13. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #13
    Are you on a 3G or 3GS ?

    Do you use an official sim (like AT&T) or un-official like T-Mobile ? If so, you cannot restore a 3GS to firmware 3.0, only to 3.1.or 3.1.2

    Read this thread, will answer your questions, it is very well done by thelatinest who knows his stuff Jailbreaking made simple
     
  14. Jedi5 macrumors 6502

    Jedi5

    Joined:
    Aug 16, 2009
    Location:
    North Burbs, IL
    #14
    3GS w/ official AT&T sim.

    I'll check that thread out.
     
  15. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #15
    Do you have your ECID SHSH on file in Cydia? If so, you can restore to 3.0, but you will first have to do some editing to your hosts file. If not, then you will only be able to restore to 3.1.2.

    If you do have to upgrade to 3.1.2, you will want to make absolutely certain to use a custom firmware to update so that you can preserve your ultrasn0w unlock. Updating to the official 3.1.2 will upgrade your baseband and make ultrasn0w useless to you. There is an unlock for the new baseband, but it is much less reliable and far buggier than ultrasn0w.
     
  16. thekarbunkler thread starter macrumors member

    Joined:
    Sep 15, 2009
    #16
    this worked great! thank you very much!
     
  17. basesloaded190 macrumors 68030

    basesloaded190

    Joined:
    Oct 16, 2007
    Location:
    Wisconsin
    #17
    No Problem. I guess it works for some and not for others. I was very happy to see it work for me, because that problem was bugging the piss out of me!
     

Share This Page