Cydia errors after TRYING to add

Discussion in 'Jailbreaks and iOS Hacks' started by psywzrd, Aug 20, 2010.

  1. psywzrd macrumors 68030

    Feb 6, 2008
    I tried to add the repo to try out Frash and it failed. Now when I open up Cydia I'm getting an error message every time (see screenshot). I don't understand why I'm getting an error message though because the repo isn't even listed in my list of sources. Any idea how I can get rid of the error message?

    Attached Files:

  2. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    You entered the repo address incorrectly, so it cannot load into Cydia and you cannot remove it via Cydia.

    You will have to SSH into your phone and manually remove the bad repo.

    If you added a source that causes Cydia to crash, this will help you remove the buggy source you added.

    You will need an ftp/sftp client. [WinSCP for Windows/Cyberduck for Mac]

    1. SSH into your iPhone/iPod, hopefully you know how to do that.

    2. Go to the root of your iPhone/iPod [/].

    3. Navigate to /etc/apt/sources.list.d/cydia.list

    4. Download the Cydia.list to your computer and open it using any text editor.

    5. Delete the source you added. For example, "deb ./" if this is the source you want to delete, simply delete that one line. NOT THE WHOLE DOCUMENT. Make sure you save the document as is. We are NOT adding any extensions.

    6. Drag the saved document into the sources.list.d folder and replace the file.

    7. Re-spring.
  3. psywzrd thread starter macrumors 68030

    Feb 6, 2008
  4. mphayvanh macrumors member

    Aug 16, 2010
    That repo is no longer valid. I was able to use that repo to install frash. I removed it because of those errors. Btw frash was great.
  5. macslayer118 macrumors 6502

    Oct 6, 2008
    Dallas, TX
    I have successfully used this method to remove XSellize repo that I apparently put in wrong, but every time I add or remove a repo Xsellize comes back. Does anyone know why or how to stop it? It's getting really annoying to have to edit this file every time :confused:
  6. detronic macrumors member

    Jul 16, 2010
    thanks: dhlizard

    had the same problem, fixed the same problem with this thread, thank you much
  7. mattla93 macrumors newbie

    Aug 21, 2010
    We were under a massive DDOS attack the last days.

    Now the Repo is up and running :)

  8. Lazer90210 macrumors newbie

    Aug 15, 2010
    I'm getting the same error when I add ispazio repo. I want to be able to download/be notified of the release of the updated LiveClock, Weather Icon and Rotation Inhibitor.

    Anyone had any luck with getting ispazio repo working on 4.0.1?
  9. elipem01 macrumors member

    Jan 24, 2009
    This can also be done using iFile if you have it.
  10. -aggie- macrumors P6


    Jun 19, 2009
    Where bunnies are welcome.
    I have ispazio on 4.0.1. The site is probably down when you’re trying to add it.

    To others: another way to fix repp errors is using Cyfix (an executable from Cydia for using in Mobile Terminal), which can get rid of even the errors that editing the Cydia.list file doesn’t fix.
  11. FireSokar macrumors regular

    Jun 21, 2010
    I used Cyfix two weeks ago when myrepospace was spazzing out. Just know you must use from within mobile terminal or a ssh connection because the Optional GUI that is offered does not properly work on ios 4
  12. fuzion11 macrumors 65816


    Sep 24, 2008
    Hamilton, Ontario
    You're the man dhlizard...your method worked like a charm for me too!

    Thanks dude!:D
  13. nozebleed macrumors 6502

    Jul 30, 2008
    this works until you add a new repo, then the bad comes back. its buried deep in the phone

    this. cyfix from xsellize repo - run with mobile term for the permanent fix

Share This Page