iPad Cydia Icon Disappeared After "Deleting All Settings"

Discussion in 'Jailbreaks and iOS Hacks' started by iMikeyy, Apr 30, 2014.

  1. iMikeyy macrumors newbie

    Joined:
    Oct 11, 2011
    #1
    Long story short there was something wrong with my App Store, "Cannot Connect to App Store" it said so out of frustration I reset all settings, which appearently got rid of Cydia and all of my jailbroken apps (iFile, etc.) so I have none of those.

    I tried to kick myself into Safe Mode by powering off, and then powering on while holding the volume up button but I don't think thats working, although I'm not 100% sure since I have no way of knowing except the Cydia app is still not there.

    I can however access Cydia by going to "Cydia://" but it is here where I don't know what to do next. I've tried to reinstall Cydia Substrate as well as Substrate Safe Mode, but nothing seemed to happen after doing that and respringing. Are there any other suggestions? Next I was going to see if I can force safe mode through SSH, but I don't believe I had SSH installed before.

    Also I noticed I Can still use a tweak (really only had the one installed) which was SpringSwitch so thats odd. I can also access flux an winterboard in the settings and change themes, the only issue is that all the icons disappeared.

    I'm really at a lost and don't really want to restore. The only thing I really NEED with my jailbreak on my iPad is iFile, but I'd obviously like to get it fully functioning again anyways.

    I also assume there is not way to restore to my current firmware version (7.0.4) without updating.
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    Try downloading the deb file for cydia: http://apt.saurik.com/cydia/debs/cydia_1.1.9_iphoneos-arm.deb

    Use iFile to install it and then respring/reboot

    You said you can access cydia using cydia:// so you should still be able to install/reinstall packages for iFile and such

    And yes, there's no way to restore to a jailbreakable firmware at this time
     
  3. iMikeyy thread starter macrumors newbie

    Joined:
    Oct 11, 2011
    #3
    I did see this suggestion somewhere and thought it would be the next best thing for me to do, however how do I get to iFile to install it? Is there anyway to on my laptop?

    I can't get to iFile even though I know it is installed (I uninstalled and re-installed) because the icons are all missing/hidden:(
     
  4. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #4
    You must never do what you did on a Jailbroken phone. I do not believe there is any way to recover without a restore.
     
  5. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    Did you try respringing after reinstalling iFile?

    You can try the cydia auto install method to install debs without iFile: http://www.idownloadblog.com/2011/06/16/manually-install-deb/

    You'll need afc2add or openssh installed from cydia to access your phone from your computer
     
  6. Mattionardi macrumors newbie

    Joined:
    Apr 30, 2015
    #6
    I have same problem here after reset all setting. I use activator to make shortcut. Now i can access ifile n other tweak. I hope this method can help you. :)
     

Share This Page