cydia issue

Discussion in 'Jailbreaks and iOS Hacks' started by spykedmartini, Dec 7, 2010.

  1. spykedmartini macrumors member

    Joined:
    Oct 16, 2007
    #1
    i just jailbroke my phone and installed a few apps, but now when i open cydia all the repositories are gone and i dont know how to get them back. my phone also keeps entering safemode but i think thats because i have bitesms 5.0 and not 5.1 that is compatible with 4.2.1 (which is the fw version i have). i want to update bitesms but now it seems like i have a bigger problem. any help? thanks!
     
  2. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
    have you got it out of safe mode? to do this go in cydia, then manage, then packages click on the download you assume is causing the issues and hit modify then remove
     
  3. spykedmartini thread starter macrumors member

    Joined:
    Oct 16, 2007
    #3
    its out of safe mode, and when i go into cydia and go to the manage section nothing appears, even though i can still open bitesms and winterboard.
     
  4. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4
    what if you add the sources back in manually do they stay?

    if you havnt tried go to manage, then sources, then edit, then add

    ModMYI is http://apt.modmyi.com

    Big Boss is http://apt.thebigboss.org/reprofiles/

    ZODTTD & MCCITI is http://cydia.zodttd.com/repo/cydia/

    Ultra Snow is http://repo666.ultrasnow.com

    Telesphoreo tangelo is http://apt.saurik.com

    those are the preinstalled ones on cydia, hope that works and helps
     
  5. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #5
    Default sources cannot be added manually, they use standardized APT structure. You need to add them using SSH with their own files and structure. If they are gone from Cydia is due to some other issue.
     
  6. spykedmartini thread starter macrumors member

    Joined:
    Oct 16, 2007
    #6
    how would i go about replacing those repositories? can i just rejailbreak? if so, then how? what kind of issue would cause this to occur?

    thanks again everyone this is really helpful!
     
  7. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #7
    thanks for correcting me i was not aware of that
     
  8. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #8
    If you can restore and re-jailbreak that would be the cleanest way out, after you re-jailbreak, make sure you install one package at the time, in order to find which one is giving you issues. Anything could be causing the issue, there is not enough information to make an intelligent guess. It could be something as simple as file corruption, to something loading a bad library.

    If you list the Apps you installed, maybe we can find what is giving you an issue. Describe exactly how did the issue started it, what was the last app you installed? did you installed any app and didn't run it until later? what Phone do you have? what Jailbreaking tool did you use? what iOS did you have before updating to 4.2.1?

    You know that 4.2.1 JB is tethered right? that means every time you reboot you need to re-run Redsn0w and use the "tethered boot" option.
     
  9. spykedmartini thread starter macrumors member

    Joined:
    Oct 16, 2007
    #9
    i tried to restore my phone so i could rejailbreak it but now its stuck in recovery mode and will not fully restore. i keep getting an error message from itunes saying that the phone could not be restored. starting to get worried :[
     
  10. spykedmartini thread starter macrumors member

    Joined:
    Oct 16, 2007
    #10
    i just tried using tinyumbrella to kick it out of recovery but ive never had to do that before so i dont know what to expect.
     
  11. spykedmartini thread starter macrumors member

    Joined:
    Oct 16, 2007
    #11
    fixed the phone. will come back if there is still a problem with cydia after i jb again
     

Share This Page