• Did you order new AirTags? We've opened a dedicated AirTags forum.

grockk

macrumors 6502
Original poster
Mar 16, 2006
360
1
Cydia doesn't respect the Settings->Sounds Keyboard Clicks toggle. As seen here or here. Other jailbreak apps like iFile have the same problem like here. In case other people on the web are looking for a solution I thought I'd post my success.

The reason is that these apps are looking at the var/root/library/preferences which does not contain a com.apple.preferences.sounds.plist. so it uses the default value of On for the keyboard clicks. Setting a symlink for the com.apple.preferences.sounds.plist in the root preferences directory to point to the mobile preferences directory fixes the issue.

Here is the file you are linking.
Mobile%20Photo%20Dec%204%2C%202009%2010%2017%2046%20AM.jpg


I did all this on my iPhone using iFile but you could just as easy do it using SSH or whatever.

Navigate to mobile preferences directory.
Mobile%20Photo%20Dec%204%2C%202009%2010%2017%2029%20AM.jpg


Copy/Link the com.apple.preferences.sounds.plist
Mobile%20Photo%20Dec%204%2C%202009%2010%2017%2039%20AM.jpg


Paste the link in the rooth preferences directory. Here is the root preferences directory showing the symlink in blue.
Mobile%20Photo%20Dec%204%2C%202009%2010%2017%2054%20AM.jpg
 

ckong

macrumors regular
Nov 12, 2009
130
0
This is very good info and is interesting. Thanks for sharing.
 
Comment

forum user

macrumors regular
Aug 28, 2008
202
0
Thanks grockk

and for those (me for example ;)), who can enter into MobileTerminal but always get the syntax on the linking wrong:

Code:
ln -s /var/mobile/Library/Preferences/com.apple.preferences.sounds.plist /var/root/Library/Preferences/com.apple.preferences.sounds.plist
 
Comment

foob

macrumors 6502
Feb 17, 2009
306
0
This is a great find. It's one of those things that's kinda obvious but no one in the world seems to have thought of it until now.
 
Comment

denohk

macrumors newbie
May 31, 2013
2
0
can anybody tell me where is the "the rooth preferences directory".
I've tried to copy and past preference.sound file it alert me whether overwrite or rename.
 
Last edited:
Comment

JPNFRK7

macrumors 6502a
Sep 27, 2012
577
326
California
Cydia doesn't respect the Settings->Sounds Keyboard Clicks toggle. As seen here or here. Other jailbreak apps like iFile have the same problem like here. In case other people on the web are looking for a solution I thought I'd post my success.

Is that long bar in your status bar a data meter? If so what tweak is it? Thank You
 
Comment

denohk

macrumors newbie
May 31, 2013
2
0
anybody tell me where is the "the rooth preference " ?

Cydia doesn't respect the Settings->Sounds Keyboard Clicks toggle. As seen here or here. Other jailbreak apps like iFile have the same problem like here. In case other people on the web are looking for a solution I thought I'd post my success.

The reason is that these apps are looking at the var/root/library/preferences which does not contain a com.apple.preferences.sounds.plist. so it uses the default value of On for the keyboard clicks. Setting a symlink for the com.apple.preferences.sounds.plist in the root preferences directory to point to the mobile preferences directory fixes the issue.

Here is the file you are linking.
Image

I did all this on my iPhone using iFile but you could just as easy do it using SSH or whatever.

Navigate to mobile preferences directory.
Image

Copy/Link the com.apple.preferences.sounds.plist
Image

Paste the link in the rooth preferences directory. Here is the root preferences directory showing the symlink in blue.
Image






denohk
macrumors newbie

Join Date: May 2013
can anybody tell me where is the "the rooth preferences directory".
I've tried to copy and past preference.sound file it alert me whether overwrite or rename.
 
Comment

Stooby Mcdoobie

macrumors 6502a
Jun 26, 2012
828
40
can anybody tell me where is the "the rooth preferences directory".
I've tried to copy and past preference.sound file it alert me whether overwrite or rename.

Typo. Should be root, not rooth, like it says in the second sentence of that same line.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.