Cydia Problem... HELP PLEASE

Discussion in 'Jailbreaks and iOS Hacks' started by brando06, Nov 2, 2009.

  1. brando06 macrumors regular

    Joined:
    Jan 5, 2007
    #1
    Ok so i was trying to install the source david.ashman.com/beta/ and i reloaded cydia and now i get Error:Database Problem parsing dependency Depends.

    How to i fix cydia?? I have no sources anymore or anything!!
     
  2. brando06 thread starter macrumors regular

    Joined:
    Jan 5, 2007
    #2
    Please folks i dont wanna have to re-jailbreak again
     
  3. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #3
    Just wait a bit, mine was doing that and now its fine.
     
  4. brando06 thread starter macrumors regular

    Joined:
    Jan 5, 2007
    #4

    How long did you wait?? It's been going on for about 3 hrs now!!
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    You can go into the plist and delete the repo...

    Get rid of troublesome Cydia source

    To remove the repo is easy but i don't think thats the problem

    Remove Cydia Sources through SSH

    If you added a source that causes Cydia to crash, this will help you remove the buggy source you added.

    You will need an ftp/sftp client. [WinSCP for Windows/Cyberduck for Mac]

    1. SSH into your iPhone/iPod, hopefully you know how to do that.

    2. Go to the root of your iPhone/iPod [/].

    3. Navigate to /etc/apt/sources.list.d/cydia.list

    4. Download the Cydia.list to your computer and open it using any text editor.

    5. Delete the source you added. For example, "deb http://www.iphone.org.hk/apt/ ./" if this is the source you want to delete, simply delete that one line. NOT THE WHOLE DOCUMENT. Make sure you save the document as is. We are NOT adding any extensions.

    6. Drag the saved document into the sources.list.d folder and replace the file.

    7. Re-spring.
     
  6. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #6
    As of when I posted it was working again.
     

Share This Page