cydia restart safe mode problem

Discussion in 'Jailbreaks and iOS Hacks' started by sovre, Mar 16, 2019.

  1. sovre, Mar 16, 2019
    Last edited: Mar 16, 2019

    sovre macrumors newbie

    Joined:
    Mar 16, 2019
    #1
    . A couple of weeks ago my jailbreak stopped working. I was running the Electra jailbreak on my iphone 7 plus with 11.3.1

    I tried reinstalling several times, using different methods - couldn't get it to work.

    Then I tried the unc0ver jailbreak. Couldn't get that to work either except one time by turning tweaks off. but when I restarted I got a strange message - don't remember exactly what, but I think something about Cydia being installed twice.

    I took a break at this point because I couldn't get any jailbreak to work.

    Fast forward to today. I once again tried to install Electra - now it's working again!

    When I restart I can even see that some tweaks are working. But my phone starts up with Cydia in safe mode every time and I can't get out.

    None of the tweaks I have installed now gave me a problem with my past Electra install, but I've tried iuninstalling the most recent ones anyway, thinking maybe one of them was incompatible.

    No effect - still getting thrown into safemode on every restart.

    Could Cydia somehow have gotten corrupted when I was trying to rejailbreak with unc0ver a couple of weeks ago??

    What do I need to do to get Cydia working properly again?

    When I look at my recent list in cydia I see a whole load of cydia stuff installed on the day I tried to jailbreak with unc0ver. They are all listed as "from Unknown" - some of them are duplicates of electra utilities and there are other more specific unc0ver things like "unc0ver jailbreak resources" - could these be the installs that are causing my problem, and if so is there a way to just delete all of them at once? It seems there is quite a lot of unc0ver-associated stuff installed.


    Thanks for your help!
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
  3. sovre thread starter macrumors newbie

    Joined:
    Mar 16, 2019
    #3
    TriJetHero,

    Thanks for your reply.

    Fortunately before I saw your message I was able to solve the problem.

    I'll post what I did here in case it might help someone else.

    Examining the package "Substitute," which is part of the Electra utilities, I found out there was some kind of problem with it - it was only "half-installed."

    So I removed Substitute and then re-installed it.

    Removing Substitute had the side-effect of erasing ALL my installed tweaks and basically putting me back at zero.

    Inconvenient - but it solved the problem!

    I have now re-installed my tweaks and everything is working fine. Glad to be jailbroken again. Jailbreaking seems to be much more complicated than it was in the good old days!
     
  4. freqrider macrumors member

    freqrider

    Joined:
    Feb 10, 2019
    #4
    Yes, you need to delete Electra from your settings/generalprofiles and dev mgmt. Then install Unc0ver, then go into Unc0ver/settings/restore rootFS. THIS WILL WIPE YOUR OLD JB! MAKE SURE YOU BACK UP YOUR TWEAK LIST SO YOU CAN RE_INSTALL THEM! Then re-jailbreak with Unc0ver and re-install all your tweaks. If you install Flame, it can export your tweak/source list and use SwipeForMore to batch install them again. Sounds worse than it is.
     

Share This Page

3 March 16, 2019