Cydia showing no packages, sources, etc.

Discussion in 'Jailbreaks and iOS Hacks' started by psywzrd, May 6, 2011.

  1. psywzrd, May 6, 2011
    Last edited: May 6, 2011

    psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #1
    I upgraded my iPhone 4 to 4.3.3 via pwnage and I installed pkgbackup to try to restore my jb apps. When I did the restore it looked like everything worked right but upon a reboot none of my jb apps were there. I tried to restore via pkgbackup several times after that and the same thing kept happening. I opened up Cydia and noticed that no packages or souces are showing up and searching for apps comes up empty. What can I do to "reset" Cydia to show packages, sources, etc.? Going into sources I get a message that says "malformed line 2 in source list /etc/apt/sources.list.d/Cydia.list (URI parse). It seems like I need to somehow rebuild the entire Cydia database or something. Any ideas? I can't even install ifile to try and navigate to wherever I need to go to fix this and I can't use ssh either since I don't even have openssh installed, right? Please help!
     
  2. psywzrd thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #2
    Ok - it seems like pkgbackup might be the cause of this. I just followed this procedure and got Cydia back to normal.

    "navigate to /var/lib/cydia/

    delete the metadata.plist...(this will remove all ur added source inside cydia and reset them to original one, so please kindly add back ur source after that)..

    and delete this files too..

    /etc/apt/sources.list.d/cydia.list

    finally, delete anything inside

    /var/lib/dpkg/updates/ (dont delete the folder)

    reboot ur iphone and open cydia.. u are done.. u got a fresh new cydia.."

    Once I did and ran a restore agin in pkgbackup, I got the same error in my post above and Cydia is empty again. Please help.
     
  3. breakhard77 macrumors newbie

    Joined:
    Jun 30, 2008
    #3
    I'm having this exact problem as well. Cydia worked fine until I downloaded PkgBackup and tried to restore the rest of my apps. I tried your suggestion to fix Cydia, but it didn't work for me, even after I deleted all of those files. Any help would really be appreciated.
     
  4. psywzrd thread starter macrumors 68030

    Joined:
    Feb 6, 2008
    #4
    Not sure why the procedure above isn't working for you. I was at least able to get Cydia back by doing that procedure. Unfortunately, I had to reinstall all of my jb apps manually because doing the restore via pkgbackup kept causing Cydia to go haywire again. I don't know if my pkgbackup was corrupted or what but it just would not work. First time I've had a problem like that with pkgbackup but very frustrating.
     
  5. Ronit macrumors newbie

    Joined:
    Feb 22, 2012
    #5
    Ok,so u don't have ifile? Use cyder for windows to install ifile onto the iPod with your computer.no need to restore and delete anything.once ifile is installed go to ifile/etc/apt/sources.list.d/cydia.list.here you will see a list of sources.now according to the error code(say malformed line 3) check the third source in the list(3),at the end of the source there will a 'stable' command,this command requires a 'main' command with it which is missing hence the error.simply leave a spacebar and type main after this stable command and save it.do the same for 2nd source if error is'malformed line 2'.ask me if u still get error.
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    use iFunBox for MAc or Win, direct iPhone file structure access through USB, no command line or SSH.
     
  7. Thunde1r macrumors newbie

    Joined:
    Dec 6, 2013
    #7
    cydia error malformed line 15 in source list dist

    delete the metadata.plist

    cydia error malformed line 15 in source list

    If that delete line 15

    and delete this files too..

    /etc/apt/sources.list.d/cydia.list

    reboot ur iphone and open cydia

    Thank psywzrd
    Original psywzrd
    I use that way to keep source
     
  8. LoLife macrumors regular

    Joined:
    Jun 1, 2010
    Location:
    Reno, NV

Share This Page