Cydia warning screen for 3.1.2

kaytoos2k

macrumors newbie
Original poster
Nov 22, 2009
4
0
I'm on 3.0 and I'm planning on upgrading to 3.1.2.

From what I understand it is now fully jailbreakable and unlockable. How come cydia still has the message:

"if you upgraded to 3.1.2 without using PwnageTool to do so you will not be able to uplock your phone at this time, and maybe forever after."

am I missing something?
 

Vandam500

macrumors 68000
Sep 29, 2008
1,821
54
That's not true. I don't know why they haven't updated that information yet but currently ALL iPhone firmwares are unlockable/jailbreakable for ALL iPhones.

The quickest way is to use blackra1n which you can download from www.blackra1n.com

I have unlocked 2 iPhones (3G and 3GS) running on 3.1.2 without a single problem. Go for it
 
Comment

andybno1

macrumors 68040
Nov 6, 2007
3,638
37
Liverpool, UK
to follow on from the above post you will need to then load blackra1n on the iPhone then install cydia and blacksn0w (this is the unlock)
 
Comment

kaytoos2k

macrumors newbie
Original poster
Nov 22, 2009
4
0
Ok, thanks for confirming. I'll finally stop procrastinating and update.

I was just curious if anybody knew why cydia still has that message.. It confused me a bit.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.