Cydia's ****ed. Won't open.

Discussion in 'Jailbreaks and iOS Hacks' started by Knowlege Bomb, Jul 30, 2009.

  1. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #1
    Does anybody have a solution for this? I just finished downloading a couple themes and now Cydia crashes on startup. Every time. I've resprung, restarted, hard resetted, applied and removed themes and other tweaks.

    Nothing works. I just got to work an hour ago so I won't have access to my computer until about 1130 tonight. Am I dead in the water or is there some method I'm missing here?
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Not sure what you want us to tell you.

    Apparently, something you installed has affected Cydia, if I had to offer an opinion.

    Not much else to say with limited information.
     
  3. Knowlege Bomb thread starter macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #3
    Well since that was the question at the end of the post, one could easily assume that's what I was wanting someone to tell me.
     
  4. Knowlege Bomb thread starter macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #4
    Anybody willing to offer advice rather than raising their post count with unhelpful "opinions"?
     
  5. MBHockey macrumors 68040

    MBHockey

    Joined:
    Oct 4, 2003
    Location:
    New York
    #5
    Maybe if you weren't such a jerk people would try to help you?
     
  6. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #6
    what themes

    did you download and did you try turning them back off and rebooting beyond that people are going to beed more info.
     
  7. IBradMac macrumors 68000

    IBradMac

    Joined:
    Jun 27, 2008
    Location:
    Ohio
    #7
    :rolleyes:

    If they are winterboard themes delete them via ssh.
     
  8. WannaApple? macrumors 6502a

    Joined:
    Jun 9, 2008
    Location:
    Florida
    #8
    Sorry to be the bearer of bad news, but this happened to me about a month ago as well. I tried all the remedies found online and nothing worked. I had to just restore and start over. You can try some of the solutions in many different threads (do a search), but otherwise you may have to just restore if nothing else works.
     
  9. The General macrumors 601

    Joined:
    Jul 7, 2006
    #9
    Do you have a way to access your iPhone's filesystem? Try deleting everything in /var/lib/apt/lists/ and see if that fixes it. If not, then try deleting everything in /var/lib/dpkg/updates/
     
  10. Knowlege Bomb thread starter macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #10
    If you take a peek at my post history you will see that I am definitely not a jerk. The first and only response for a good amount of time was somebody telling me something I, and anybody else, could have figured out as soon as the issue appeared.

    Read the OP. Specifically the part about not being around my computer until 1130 tonight.

    Looks like that's going to be the only option other than a restore. The original point of the thread was to see if anybody had experienced a similar issue and had found a way outside of using computer access. Thank you for your professional-mannered response.
     
  11. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #11
    *
     
  12. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #12
    Yeah i have the same problem and ive pretty much accepted that i have to restore but i'd like to wait til 3.1 comes out because i also have a problem in that i cant backup anything in iTunes since ive had 3.0

    So....i dont want to keep installing everything over and over again and reconfiguring over again so i hope 3.1 comes out soon and there will be a jailbreak within days of it coming out.
     
  13. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #13
    I finally broke down and did a jailbreak with 3.0.1, but after installing some themes for Winterboard through Cydia, Cydia itself won't load.

    During install of iIllumine (I believe), the phone cut off and rebooted without prompt, and from what I saw on the screen, this happened before the install was complete. It may have also been iElegance (not sure now).

    Anyway, the reboot never came up so I had to use the Power+Home for about 10 seconds to force a shutdown, then reboot. Now Cydia will try to open, but quit unexpectedly before loading.

    If anyone has any suggestions that would be great. I've installed OpenSSH, but didn't configure anything, so not sure I'll be able to get in, but if I can...how?

    Thanks,
     
  14. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #14
    That happened to me on 3.0
    Working fine with 3.0.1, you may have to do a restore. Mine never came back until i upgraded.
     
  15. Ramsteiner macrumors member

    Joined:
    Sep 3, 2007
    #15
    It's happened twice to me on 3.0. The fix is easy. SSH or DiskAid or Phoneview into your iphone. Go to /private/var/lib/apt/lists
    and delete all the files in /root/private/var/lib/apt/lists/ except for the partial subfolder. Do not delete Partial folder. Restart Cydia and it should work just fine. Just had to do this yesterday.
     
  16. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #16
    I'll try. I installed OpenSSH before this happened, but have never tried to ssh in. I'll have to find a tutorial, and if any preconfiguring was required, I'm probably screwed.

    Is there a way to get Icy on it without using Cydia to insall the other apps you mention (DiskAid, PhoneView)? Or maybe MobileTerminal will let me do this if I can get it installed? Or will OpenSSH work without configuration from a Mac?

    Thanks again
     
  17. egk69 macrumors 6502

    Joined:
    Dec 5, 2008
    #17
    Everyone!!!

    Do what this guy sais!, i was going to write that...

    It has work every time for me!


    Don't restore unless that doesnt work...
     
  18. Ramsteiner macrumors member

    Joined:
    Sep 3, 2007
    #18
    DiskAid and PhoneView are Mac applications that allow you to connect via USB to your Iphone. PhoneView is my personal favorite. Your Iphone will have root access if Jailbroken (obviously since you have Cydia installed). You simply navigate to the correct location, highlight the previously mentioned entries and hit the delete button in the Toolbar. Takes about 20 seconds the first time you do it. You can also move files to and from the desktop so you can keep backup copies of the entries if you like before you delete them.
     
  19. mdwsta4 macrumors 65816

    Joined:
    Jul 23, 2007
    #19
    yup, this has happened to me as well. doing this fixed the problem.

     
  20. BRIKZ macrumors newbie

    Joined:
    Jul 8, 2008
    #20
    Thanks guys this has been killing me for 4 days.....and apparently the deleting of the files fixed the problem...i thought it might have had to do with the itunes upgrade...whewwww.

    Question tho...why does this work? and what are these files for?
     
  21. Hackcomic.com macrumors regular

    Joined:
    Dec 6, 2003
    #21
    I'm having the same problem even after I updated to 3.1 Sadly though when I go through all the folders and get to Partial Folder- there are no other files except that folder. So there is nothing to delete.

    Still can't get cydia to work
     
  22. JennaLDS macrumors 6502

    JennaLDS

    Joined:
    Jul 23, 2009
    Location:
    Utah!
    #22
    I tired this, and Cydia still will not open. I restarted the phone as well, and it still crashes when loading up. any ideas?
     
  23. mattypad2 macrumors newbie

    Joined:
    Jan 26, 2010
    #23
    I have a problem too

    So I just jailbroke my iPod touch 4g, with redsn0w 0.9.6b3 cuz I dont have saved shah blobs for 4.1. I'm on 4.2.1.
    So, I tried to open up cydia for the first time, and it just opens up and immediately closes
    How do I fix this so I can open cydia?
     
  24. bute76 macrumors newbie

    Joined:
    Jan 7, 2011
    #24
    I had the same problem. I'm not sure how to fix it?
     
  25. transam7816 macrumors regular

    Joined:
    Mar 7, 2008
    #25
    get into safe mode and see if you can get into cydia
     

Share This Page