D-Link DI-624 Internet Connection Problems with PowerBook

Discussion in 'PowerPC Macs' started by jasonar, Dec 3, 2005.

  1. jasonar macrumors newbie

    Jun 17, 2004
    Alexandria, VA
    I have 2 computers connected to the DI-624 router, the PC works flawless, the Mac has issues with the internet access.

    The PowerBook connects to the router with an excellent signal, but the internet connection is where im having some difficulities. Once I am connected and attempt to visit any website, I will get "connecting to macrumors..", it will stay that way for about a minute, then finally load the page SLOWLY. I have the same issue whether the PowerBook is connected via ethernet or wireless. The only way that I am able to connect the PB without these issues to connect it to one of the Vonage (connected to one of the D-Link ethernet ports) ethernet ports.

    I have tried talking to D-Link Level 3 support, but after about an hour of troubleshooting, they were clueless as to why the PB was having issues with internet access. They didn't think it was an issue with the router, because the PC works without any issues.

    Additional info on the router:
    DI-624 C3 revision
    2.70 firmware (tried all availalble firmware with same results)

    I would appreciate any help with this problem.

  2. ddrueckhammer macrumors 65816


    Aug 8, 2004
    America's Wang
    I have a Rev C powerbook and my dad has a DI-624 at his house. There are no problems for me connecting to it. Perhaps try checking your router's security settings. My dad's uses 64-bit WEP encryption which while not the best allows his slower PC laptop to connect just fine. To check the settings on this router open Safari and go to the ip address:

    The default username is: admin and the password is whatever you have set it as. Default is blank I think.

    Once you are there, you can check all of the settings on the router to make sure they are correct.

    On the Powerbook you may want to check your Network settings in the system preferences by going to Show: Airport in the drop-down. Make sure that you have join by default set to automatic and DHCP is configured for most ISPs. Also, you might want to try turning off your built-in firewall under System Preferences>Sharing.

    Finally, how far away is the router from your laptop. A longer distance will lead to a degraded signal. Also, do you have any microwaves or cordless phones that could be interfering with your signal. My girlfriend constantly complains about her signal but she lives in an apartment with people living on three sides of her. Most likely, there is always someone cooking something in a microwave or using a cordless phone on the same bandwidth.

    Just some thoughts, hope they help!

Share This Page