D90 Autofocus Issue? Please Help!

Discussion in 'Digital Photography' started by mikeschmeee, Sep 19, 2009.

  1. mikeschmeee macrumors 6502a

    Mar 9, 2009
    Hello Everyone,

    As you may or may not know (doesn't really matter though) it was my 24th birthday on Friday (sept 18) and so I set out today (sept 19) to purchase a new camera, Nikon D90, from Broadway Camera in Richmond, B.C.
    It's a work of art but one problem. NO AUTOFOCUS! From what I read the AF dot will display and stay solid in the view finder when the subject is in focus or it will blink when it is out of focus. That seems to work but when I want the camera to focus automatically nothing happens. I've changed lenses and still no results. It's not that big of a deal since I mainly focus manually but at the same time it kind of is and it would be nice to know that my new DSLR is not broken.

    Both body and lens are on autofocus but it does not display AF-A, AF-S or AF-C in the control panel. It does not display anything. I press and hold the AF button and turn the command dial that's right under it nothing happens. When I press the INFO button it says MF where it should say AF-A, AF-S or AF-C.
    There's no way to change it on the camera. I've read the entire manual and researched online whether it is some type of firmware problem or lens compatibility (I'm using a Nikon Nikkor AF-S 18-200mm VR)

    EDIT: Also, when I press the menu button and go to custom setting menu then choose autofocus, a1 AF-area mode is grayed out and I am not able to select it. If I press the OK button it says "this option is not available with current settings"

    Please help I have tried everything and all signs lead to a defective unit.

  2. Elbert C macrumors 6502

    Mar 23, 2008
    AK, USA
    Have you tried cleaning the contacts on the lens and body mounts?
    Reset it to factory conditions?

    BTW Happy Birthday.
  3. mikeschmeee thread starter macrumors 6502a

    Mar 9, 2009
    Yes, I have cleaned mounts gently and no results.
    I have reset custom settings when i press the menu button but not a complete reset to factory settings. Not too sure how to do that.
    Thank you for the birthday wishes
  4. gnd macrumors 6502a


    Jun 2, 2008
    At my cat's house
    Do you have the AF/M switch (auto focus / manual focus) turned to MF (manual focus)?

  5. mikeschmeee thread starter macrumors 6502a

    Mar 9, 2009
    The switch is turned onto AF. Nothing happens... It does not focus automatically.





    Sorry for the low quality pictures quickly taken with my iPhone with bad lighting but as you can see everything seems to be correct and still no dice.
    See the MF near the center of the LCD display? That does not show up on the control panel display on the top of the camera. Nor can I change it here or when I press the menu button and do it through there.
    What to do? Go and exchange it for a new one at the store tomorrow? I'm hoping there is some hidden feature on the camera that enables it and just makes me look like a rookie instead of going all the way back and returning the camera.
  6. mikeschmeee thread starter macrumors 6502a

    Mar 9, 2009
    Alright, this is really strange. I brought the camera back to the store today, we attached a 18-105mm lens from a D90 that was on display and the autofocus works. I grabbed my lens (18-200mm) and attached it to the D90 and guess what... IT WORKS!
    So here is my question... what happened? How did the autofocus fix itself in between the time I went to sleep and woke up the next morning to take it back to the store to see if it can be exchanged?!? I don't understand, can anyone make sense of this? Whatever happened is fine with me my new camera works 100% and I'm very happy but until I figure it out I guess the "Nikon Fairy" came and spread some pixie dust onto the SLR to make it work. (as childish as that sounds)

    I'm off to snap some photos.
    Thank you all.


    :D :D
  7. Designer Dale macrumors 68040

    Designer Dale

    Mar 25, 2009
    Folding space
    Auto focus is electronic and thus subject to the demons of the electron stream. Consistent failures are easy to deal with but these inconsistent failures are perplexing. I've repaired a number of electronic devices (not cameras) by disassembling/reassembling them. It doesn't take much to mess up the contact on something delicate like this. I would remove and replace the lens every day for a week and make sure the problem doesn't reappear the next time you change the lens.

  8. artochat macrumors newbie

    Sep 25, 2009
    Exactly Same Thing Happened To Me Today!!!

    Yes, all the photographs of camera settings you posted are the identically same as mine and the problem was exactly identical. I bought my D90 six months back, I did not use it much but today when I was really using it I faced this problem. I also went through the manual thoroughly but could not find an answer. Here I should mention I read the manual properly before using it. I read it properly again after having the problem.

    Getting frustrated I searched on the net. FINALLY I also got the solution in a similar way which has no apparent explanation. I detached the lens and again attached it. NOW THE DISPLAY IN CONTROL PANEL IS BACK!!! AND THE a1 AF-area mode is also working!!! But I detached the lens earlier also after having the problem, at that time the problem persisted after attaching. After reading your writing when I did the detaching and attaching I got the result. No logical explanation!!!
  9. carlosbutler macrumors 6502a


    Feb 24, 2008
    London City
    i believe the way most of these things work in programming terms is that when you connect a lens to the camera, the lens it self has information built in to it. some lens also have built in motor's, some need the camera to turn it.

    when the lens is connected, the camera may think that a lens is connected but is only a manual one. luckily i have never had this problem, although i have a D80
  10. mikeschmeee thread starter macrumors 6502a

    Mar 9, 2009
    I know! This is completely weird but so far so good. I'm having a blast with my D90! :D
    I contacted Nikon and they didn't even know, the rep told me to return the unit to the store since its brand new.

    Glad to hear that this thread helped someone else other then me :)

  11. pdxflint macrumors 68020


    Aug 25, 2006
    Oregon coast
    Sometimes when mounting a lens, the electronic contacts might not make the perfect connection, especially if the lens doesn't really "click" into locked position. Remove, and remount the lens when that happens - normally this should do the trick. And, try turning the camera off, then back on - sometimes with electronic devices, they get "stuck" with some erroneous signal, and only shutting them off resets them.

    But, if it happens frequently, I'd get the camera exchanged for another one. It could be a slight misalignment in the lens mount or something like that. Put it through some serious paces the first couple of weeks to see if it might be a long-term problem.
  12. An7rax macrumors newbie

    Dec 30, 2009
    Same problem

    I got my D90 in September this year with 18-200 Nikkor lens. Everything was perfect until today when I tried my new Sigma 105 macro lens. At first I thougth they tricked me , sending me a lens without autofocus. Later on I figured how AF should work with this lens , but surprise surpise- NO AUTOFOCUS AT ALL. I have tryied my previous lens - same situation - no AF , no AF options at all. Finally I started looking for someone with similar problem in the WEB and here I go. Unfortunately I had no luck so far with my attempts to get this camera to work properly again. I have tried to clean the contacts , changed the lenses couple of times , turned the camera on and off, recharged the battery, I had my eyes crying while I was reading the stupid manual 100 times:mad:...No change. I will probably have to send this fellow for repair. Any other suggestions anyone ?
  13. compuwar macrumors 601


    Oct 5, 2006
    Northern/Central VA
    Does changing from servo to continuous AF make a difference?`
  14. An7rax macrumors newbie

    Dec 30, 2009
    AF options are completly unavailable just like mikeschmeee's problem described above . Pressing the AF button and turning the main wheel does not seem to cause any reaction in the camera.:mad:
  15. An7rax macrumors newbie

    Dec 30, 2009
    I managed to solve the problem . I 've never changed my lens in the past since I did not have another one. Today I realized that once fitted the lens needs to be turned slightly to the side opposite to the one you turn it during the attachment process. When I turn it this way it clicks and after that all the autofocus options are available and the camera works perfectly with both the new and the old lens. I am really happy that I figured out how to fix it myself as I didn't want to send it for repairs. I hope that this might help to someone with the same problem. No ghosts or fairies were involved :D
  16. dinette00 macrumors newbie

    Jan 31, 2010
    Thank you so much

    Hello everyone,
    Thank you so much for your help, I had the problem this morning with my new D90, I was so freaked out... First I didn't read the entire responses... so I tried changing lenses, cleaning the contacts, reseting custom settings, turning the camera on and off, recharging the battery but still MF in the INFO panel. Hopefully I read the full responses and saw the last one. I tried to turn the lens slightly to the side opposite and heard the providential "click"! Too late for me to test the morning light to make some picture, I will try instead the evening light... :)
  17. ljohnl macrumors newbie

    Jul 14, 2010
    >D90 Autofocus Issue? Please Help!

    okay, I had the same issue with auto focus on my Nikon d90. How did I fix that? easily, first, to detach the lens you are supposed to push and hold "lens release button" what I did, and, when I was attaching another lens I simply pushed same button! - that is a mistake! you do not need to push "lens release button" when attaching the lens. just attached it, turn until you hear "click" and enjoy...
  18. atkthulasi macrumors newbie

    Apr 16, 2013
    hi......m using nikon d90 cam with 18-105mm lens . the AUTOFOCUS was working for last one year . Now it is not working even though all the options related to it are switched on. i have removed the lens and refitted it after wiping the contacts. that was also not clicking. can anyone help me out on this?:confused:
  19. mikeschmeee thread starter macrumors 6502a

    Mar 9, 2009
    Did you drop the lens or camera recently? If so, maybe that ruined the sensors around the contacts that engage the autofocus?

    Bring it to a camera store and see if they can help. Maybe you just need to keep reattaching the lens until the autofocus comes back?

Share This Page