Damaged 2012 Mac Mini only boots Windows!

Discussion in 'Mac mini' started by Bollockser, Mar 13, 2017.

  1. Bollockser macrumors regular

    Joined:
    Oct 28, 2014
    #1
    My beloved quad-core i7 2012 mini was damaged last week in a freak anomalous electrical surge from a dubious firewire cable, which may have accumulated static or perhaps not been properly shielded from a cable wire it was touching. The firewire port made a loud pop when I plugged it into the Mac, and then I immediately smelled burning circuit board. The firewire soundboard at the other end of the cable was not turned on, and the power strip it was connected to was shut off. I dont understand how this could have happened.

    However the Mac is not totally dead, but now it only will run Windows.
    My El Capitan partition will not finsih booting
    El Capitan recovery partition will not finish booting
    Mountain Lion, El Capitan, and Sierra USB system installer flash drives will not finish booting - but the USB ports are still working.

    So any Mac OS partition, the progress bar is painfully slow, and if it ever gets to the end, the mac just sits there and the OS never mounts.

    BUT,
    Windows 7 boots and runs just fine, as if nothing is wrong. Windows device manager shows that my firewire controller and Bluetooth controller are non-functional.

    So, my theory is that MacOS refuses to finish booting because it can detect that there is hardware damage, whereas Windows just does not care.

    Has anyone ever heard of such a thing? A Mac that will only boot to Windows?
    I've no longer got a Macintosh, I've got an Apple PC.

    I could live without firewire and bluetooth, but I can't live with a Mac that wont run MacOS!
     
  2. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
  3. Bollockser thread starter macrumors regular

    Joined:
    Oct 28, 2014
    #3
    All items say "ok" in the health tab.
    Hard drive is OK, I have booted a MacBook Pro with it via USB

    If I could get the Mac to boot MacOS, I could live without firewire and bluetooth but this is just madness only being able to run Windows.
     
  4. now i see it macrumors 68030

    Joined:
    Jan 2, 2002
    #4
    Loud pop & smoking electronics = fried computer. Bummer.
     
  5. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    Does safe mode (hold Shift on startup) work? What about a PRAM/SMC reset?

    If you use your other Mac to install El Cap directly to a USB, does the Mac Mini then boot into that macOS USB stick? If it does, you can try to see if the macOS partitions show up there, so your data will hopefully be recoverable.
     
  6. Bollockser thread starter macrumors regular

    Joined:
    Oct 28, 2014
    #6
    I reset PRAM and SMC, no change. Holding shift for safe mode did not boot to safe mode.
    I also held down the D key and ran the Apple Hardware Diagnostic, no problems were detected except a common false flag related to SSDs.

    My regular partition, my recovery partition, and 3 different versions of OSX USB installers refuse to finish loading, they all go slow as hell, and when they finally get to the end of the progress bar, the mac just sits there.

    Windows on the other hand seems unaffected.
     
  7. jpietrzak8 macrumors 65816

    jpietrzak8

    Joined:
    Feb 16, 2010
    Location:
    Dayton, Ohio
    #7
    Just a guess here, but maybe it isn't that macOS is detecting hardware damage, but rather it is attempting to communicate with the damaged hardware and simply failing to receive a recognized response from it?

    I suspect that Windows often has to run on hardware that is a lot more iffy than Macs are, and is probably more robust when dealing with strange or broken devices...
     
  8. Bollockser thread starter macrumors regular

    Joined:
    Oct 28, 2014
    #8
    Righton, that is where I'm hoping to lead the conversation - does anyone know how to make the mac ignore any such issues and boot anyway?
     
  9. jpietrzak8 macrumors 65816

    jpietrzak8

    Joined:
    Feb 16, 2010
    Location:
    Dayton, Ohio
    #9
    You might boot into Windows 7, and see if it indicates that any other devices beyond firewire and bluetooth are non-functional. It may be possible that the damage is more extensive...

    (I was going to suggest trying to boot with a flash drive, but you've already beaten me to the punch on that one. Might also try a Linux installer; you can often get more detailed diagnostic info from Linux than from other OSs.)
     
  10. CaseyGV macrumors member

    CaseyGV

    Joined:
    Dec 28, 2016
    Location:
    Colorado
    #10
    Not that this will help, but this is the exact behavior I encountered with my 2010 Mac mini when I got the resolution set to an incompatible setting with my HDTV. Nothing I could do would coax macOS into displaying properly after that on that TV, but Windows 10 would run just fine on it. No amount of safe mode, resetting the SMB, zapping the PRAM, or anything would allow me to see macOS after the booting progress bar would fill in. The only way I could fix it was a complete wipe and restore of the macOS partition.
     
  11. Bollockser, Mar 13, 2017
    Last edited: Mar 13, 2017

    Bollockser thread starter macrumors regular

    Joined:
    Oct 28, 2014
    #11
    I can see it just fine, it just wont finish booting. Gets to the end of the progress bar, terribly slowly, and then never goes to the login screen.

    5 days on, and no other components are showing as malfunctioning in windows device manager.
    Mac safe mode does not even respond, it's exactly the same as regular boot. Weird.

    When I put my 10.8.5 installer stick in, the wheel just spins forever and it never finishes loading. The newer OS's never reach the end of the progress bar.

    It would be nice if I could somehow get into Terminal and tell the Mac to ignore the damaged components. Not seeing any way out of this though
     
  12. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #12
    What follows is speculation.
    I've never had the need to try it, but...

    My guess is that -- during the boot process -- the OS is attempting to load the kexts that govern firewire and bluetooth.

    I'll also guess that during this kext loading process, one of the things that happens is as the kext loads, the OS "polls" the device (related to the kext), perhaps to "initialize" it and prepare it for use.

    However -- because of the damaged firewire and bluetooth controllers or ports, the "result" of the poll is inconclusive or null, and -- at that point -- the boot process grinds to a halt, waiting for the kext to load and report back to the OS (which it can't).

    What -might- serve as a workaround -- and allow the boot process to continue -- is to REMOVE the kexts that govern the firewire port and bluetooth.
    Once done, they won't load (not there) -- no "polling" -- no failed initialization to get in the way of the boot process.

    Personal experience that might have relevance:
    Back around 2011, the firewire port on my 2010 MacBook Pro stopped working. System Information reported "no firewire ports found". But of course, the firewire port was there.

    I took it to the genius bar, and they replaced the motherboard.
    Firewire port worked again, for a while, and then...
    ... it disappeared again, with the same report "no firewire ports found".

    So... I decided to let it go, until...
    ...I tried upgrading to 10.7 on a second partition on the MacBook.
    I rebooted, and then, to my amazement... the firewire port was alive again.

    I'm going to -guess- that this had something to do with the kext loading process, that the hardware had been OK all the while, but the failure of the kexts (that govern firewire) to load properly had resulted in the OS booting without "recognizing" the presence of the firewire controller and ports.

    The fresh OS install fixed that.
    The firewire on the old MacBook works to this day.

    I'm wondering if this could be "turned around 180 degrees" in your case -- that by disabling the kexts, you could bypass whatever is halting your bootup.
    Of course, firewire and bluetooth won't be alive afterwards.
     
  13. Bollockser thread starter macrumors regular

    Joined:
    Oct 28, 2014
    #13
    Great idea Fishrrman, I will try it, if it's possible.
    So I would need to mount my SSD in an external case on another Mac, then dig into my system libraries or where exactly? I seem to remember removing kexts a while back for some other purpose.

    So if anyone knows the exact directory locations of these kexts on El Capitan please advise, thank you.
     
  14. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #14
    Have you tried to boot to Internet Recovery? (Restart, holding Option-Command-R)
    You would see a rotating globe (not the usual Apple icon at boot), as it boots to Apple's remote servers, not your hard drive.
    You would also see that you are offered Mountain Lion as the original system to install on your mini, and not a later version (if you have upgraded to a newer macOS)
    If you can't boot to internet recovery either (and I suspect that will happen), then the issue is the damage on your logic board.
    I don't have any encouragement (or knowledge) about software/kext changes that you can make that might ignore the damaged chips.
    Best way - If you want to use macOS, then you will need to have the logic board repaired/replaced.
     
  15. Bollockser thread starter macrumors regular

    Joined:
    Oct 28, 2014
    #15
    Yep, tried internet recovery, never completes booting, like all the other attempts at booting MacOS.
    I'll try the kext removal method and report back.
     
  16. sorcery macrumors regular

    sorcery

    Joined:
    Mar 27, 2016
    Location:
    Ring of Fire
    #17
    So terribly sorry but that sentence I found hilarious, never heard of such a thing.
    I suspect you need to take the machine to a technician to ascertain the exact extent of the physical damage.
     
  17. rybitronn macrumors newbie

    rybitronn

    Joined:
    Jan 18, 2017
    Location:
    Celina, TX
    #18
  18. cobracnvt macrumors 6502

    cobracnvt

    Joined:
    Apr 6, 2017
    #19
    Sorry to hear about your issue. The Mac mini 2012 is a great version. Have you had it a long time?
     
  19. munakib macrumors 6502

    Joined:
    May 22, 2011
    #20
    Change the internal HDD/SSD. It's not too difficult. Then internet restore or just make a bootable sierra.
     
  20. Bollockser thread starter macrumors regular

    Joined:
    Oct 28, 2014
    #21
    You didnt actually read or comprehend any of my posts did you.


    Anyway UPDATE - I finally got it to boot to MacOS 10.8.5 off a USB flash stick with Mountain Lion installed on it using another mac. I deleted all firewire extensions on this other machine, then plugged it in and it my damaged mac finally booted to MacOS for the first time in a month! Same procedure would not work on newer OS's. So now I've got an Apple PC and a Mac on a stick :)
     
  21. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
    #22
    why wouldn't it work on the newer OS? gives you the 'forbidden' logo?
     

Share This Page