DAP plugin for Safari

Discussion in 'Mac Apps and Mac App Store' started by drumpat01, Dec 21, 2005.

  1. drumpat01 macrumors 6502


    Jul 31, 2004
    Denton, TX
    ok i installed Download Accelerator Plus for my iBook and after a few trys decided to get rid of it. So i doubled clicked the uninstall icon, but nothing really happened. The icon appeard in the dock for like 2 seconds then went away. I figured well i guess thats it and drug everything else into the trash. Well when i went to download anything from then on I get this error message that says

    "DapPlugin is unsable to find Download Accelerator Plus Application.
    please make sure to launch DAP to complete installatioon."

    then safari takes me to a page that says....

    "Safari can't find the file. No file exists at the address “/Applications/Dap.app/Contents/Resources/PluginPage.htm”.

    So i figured maybe the plug in wasn't gone. I did a spotlight search for everything that had DAP in it and trashed it all, but i still get the same message. i even tried running Firefox and it gives me the same message too. I ran firefox in safe mode and still the same message. I looked at Safari's list of installed plug ins and it says its still there but I cant i've searched for the plug in file and its not anywhere on the mac.

    Somebody help me. Id like to be able to download stuff again.
  2. pulsewidth947 macrumors 65816


    Jan 25, 2005
    What about installing it again then trying the uninstaller one more time?

    Download catchers usually have a key that bypasses the program - shift, alt, cmd, one of those.. Try pressing one of them if you need to redownload the program. What about ctrl+clicking, does that give you an option?

    If the worst comes to the worst, get firefox off someone and use that to download (then ditch safari and all its crashing goodness!)
    - Sorry didnt see that you'd already tried that!

    BTW - I just looked on DAP's website and it says:
    Good luck :)

    :EDIT: I presume you've done all the usual - repair permissions, trash preferences, reset safari (backup safari bookmarks first), restart mac?
  3. lem0n macrumors regular


    Mar 12, 2005
    I have the same case as the OP and I've tried everything, the uninstall progrmam that is included doesn't work. It appear for a spilt second and dissapear right awayand now web browser says I need the DAP plugin, but I can download like normal but Alt + click the file
  4. exdc macrumors newbie

    Nov 14, 2007
    Here's how to uninstall DAP 2.1.0

    I installed this app a few days ago, couldn't see it helped anything, only noticeable change was it was harder to find my downloads. Uninstalled it. I thought. Uninstalled it again. Repaired permissions etc. Each time I uninstalled, like you I got the messages about not being able to find the plugin etc. Here's what you do. Go ahead and use "Uninstall" - it doesn't appear to hurt, but it's not enough. Do like Speed Bit says and also erase the DAP app. Since we know that is not enough there's a final step: look inside the Users Library folder, in the folder for Contextual Menu Items. Find the file DapCMI.plugin and erase it. Now find the Internet Plug-Ins Folder, and erase the DapPlugin. Now go the same Library folder, open the Preferences folder, and find and erase the files com.SpeedBit.Download_Accelerator_Config.plist and com.SpeedBit.Download_Accelerator_Temp.plist. With a bit of luck it's fixed.

    Absolute final step: Do not re-install. Anyone that produces sw with a well-known consistent bug and doesn't squarely address the consistent bug in so many terms doesn't deserve space on our drives.
  5. majorlafrime macrumors newbie

    Dec 28, 2008

    J'ai eu exactement le même problème (DAP uninstall faills).
    Cela fonctionne à nouveau grâce à "exdc".
    Je tiens à le remercier vivement et lui souhaiter mes meilleurs vœux pour 2009 !
  6. caraoka1 macrumors newbie

    Jan 17, 2009
    I did what u said and now well when I am about to download a file, sarari or firefox error and quit, what is that <exdc> thing?
  7. toho8733 macrumors newbie

    May 26, 2009
    Thank you exdc!!! I've been trying to get rid of this thing for 2 years (no kidding) It was interferring with my downloads - some would, some wouldn't. Now that little devil has disappeared for good. One thing that was different from your instructions was I couldn't find a DapCMI.plugin in the Contextual Menu Items folder, but I may have deleted it before and don't remember. Everything else was done exactly as you said and wahoo!! it was gone and I could download everything finally. Thanks again.

Share This Page