DarwiinRemote and Nestopia not communicating

Discussion in 'Mac and PC Games' started by splooie20x6, Apr 9, 2010.

  1. splooie20x6 macrumors newbie

    Joined:
    Apr 9, 2010
    #1
    I just bought my first MacBook a few weeks ago and I'm taking advantage of some of the features available, so I decided to try the DarwiinRemote app and see it work with an NES Emulator. I'm having some issues communicating from the Wii Remote to Nestopia though.

    I have DarwiinRemote 0.6 and Nestopia 1.4.1 with the Emulator Enhancer (although I haven't payed the $30 quite yet). All my key strokes are properly mapped in DarwiinRemote, matching up with the keyboard configuration in Nestopia, however, it doesn't work at all. I can press the keyboard keys to play the game and it responds fine but the Wii Remote doesn't do anything.

    I tried to see if the Wii Remote responded in other applications and it works fine, so the problem isn't with DarwiinRemote, it seems to be with Nestopia. Am I missing something, or do I need to pay the $30 to activate it? I'd like to know it works before I do that. Or is there another popular emulator that I can download that won't have this problem?

    Thanks for your help!
     
  2. Norman15 macrumors newbie

    Joined:
    Apr 9, 2010
    #2
    I have been having the same problem recently with Snes9x and Sixtyforce. It used to work with Snes9x but now it works with neither. Hopefully someone knows what the problem is.
     
  3. fangman macrumors newbie

    Joined:
    Apr 13, 2010
    #3
    I have the same problem with SNES 9x and Darwiin not communicating. The remote works perfectly outside of SNES 9x. For me the only thing i did differently was update the latest OS X software (10.6.3), maybe it could be linked?
     
  4. abeaulieu macrumors newbie

    Joined:
    Apr 15, 2010
    #4
    I also got this problem after installing the update 10.6.3. Now Nestopia and SNES9x don't get the input from DarwiinRemote. All other applications seem to be getting the input though...
     
  5. billbrasky82 macrumors newbie

    Joined:
    Apr 18, 2010
    #5
    I am having the same issue seemingly with every emulator I have used. I get it with the snesx, nestopia and dolphin

    I got this with 10.6.2 and 10.6.3

    Anybody have any ideas?
     
  6. cy.bear macrumors newbie

    Joined:
    Apr 20, 2010
    #6
    Same thing here, emulators don't work but FrontRow, Finder, etc do.

    MBP
    OS X 10.63
    2.53 GHZ C2D
    4GB DDR3
     
  7. nervekeg macrumors newbie

    Joined:
    Dec 3, 2009
    #7
    +1 for me also,

    I can no longer use Darwiinremote with emulators

    Have searched various forums, but no joy.
     
  8. rascal-helper macrumors newbie

    Joined:
    May 12, 2010
    #8
    I spent a good 6 hours trying to figure out why I couldn't get DarwiinRemote and SixtyForce to work with each other using the Classic Controller. I'm guessing it's because no one can.
     
  9. jordanmchugh macrumors newbie

    Joined:
    Jun 22, 2010
    #9
    +1 For me too! I'm surprised this has been un-fixable for a while? I only got darwiin this week hope it gets fixed soon, fingers crossed, can't wait to play the old Nintendo games with good controllers
     
  10. Vyruz Reaper macrumors regular

    Joined:
    Dec 23, 2009
  11. dial8 macrumors newbie

    Joined:
    Jul 7, 2010
    #11
    fix

    I had this problem with DarwiinRemote+SNES9X, 10.6.3. It's apparently a problem with these emulators using an outdated method to catch keypresses.

    I found a workaround here:
    http://stackoverflow.com/questions/2379867/simulating-key-press-events-in-mac-osx

    A patch for DarwiinRemote:
    Code:
    --- AppController.m	(revision 240)
    +++ AppController.m	(working copy)
    @@ -1598,14 +1598,11 @@
     
     
     - (void)sendKeyboardEvent:(CGKeyCode)keyCode keyDown:(BOOL)keyDown{
    -	CFRelease(CGEventCreate(NULL));		
    -	// this is Tiger's bug.
    -	//see also: http://www.cocoabuilder.com/archive/message/cocoa/2006/10/4/172206
    +	// Send system-wide event that e.g. snes9x can see (accessibility API)
    +
    +	AXUIElementRef axSystemWideElement = AXUIElementCreateSystemWide();
    +	AXUIElementPostKeyboardEvent(axSystemWideElement, 0, keyCode, keyDown);
     	
    -	
    -	CGEventRef event = CGEventCreateKeyboardEvent(NULL, keyCode, keyDown);
    -	CGEventPost(kCGHIDEventTap, event);
    -	CFRelease(event);
     	usleep(10000);
     }
    I've also attached a copy of DarwiinRemote compiled from svn with the above change. YMMV. (You'll need to remove ~/Library/Application Support/DarwiinRemote/* before running.)
     

    Attached Files:

  12. Newrougecolor macrumors newbie

    Joined:
    Jul 14, 2010
    #12
    I've also attached a copy of DarwiinRemote compiled from svn with the above change. YMMV. (You'll need to remove ~/Library/Application Support/DarwiinRemote/* before running.)[/QUOTE]


    Hello

    I've been trying to install the new version you provided of Darwiinremote but for some reason it is not working. I then thought it was because I had to remove ~/Library/Application Support/DarwiinRemote/*, but it is simply not there in the specified folder.

    The error message I get with darwiinremote is :

    The managed object model version used to open the persistent store is incompatible with the one that was used to create the persistent store.
     
  13. dial8 macrumors newbie

    Joined:
    Jul 7, 2010
    #13
    Yeah, that's the error you get when it finds the old version of the coredata persistent store. The filename wasn't updated in the SVN version -- oh well.

    You should be able to run this in the terminal:
    Code:
    rm -v {,~}/Library/Application\ Support/DarwiinRemote/DarwiinRemote0.7.xml
    
     
  14. Newrougecolor macrumors newbie

    Joined:
    Jul 14, 2010
  15. kevko1976 macrumors newbie

    Joined:
    Jul 17, 2010
    #15
    can someone explain this in idiot terms? Do you have to enter that line of code somewhere? I know nothing about programming so any help is appreciated!!

    EDIT: ok, im using SNES9x and i got it working except for one thing; i have to use the directional pad on the wiimote, the one on the classic controller doesnt seem to work...any ideas why?
     
  16. fobia79 macrumors member

    Joined:
    Jun 15, 2010
  17. bmb012 macrumors 6502

    Joined:
    Jul 25, 2006
    #17
  18. lovingkindness macrumors newbie

    Joined:
    Aug 15, 2010
    #18
    It's Working!

    Thanks, dial8. Your attachment and instructions did the trick! I was going crazy: I thought maybe the dvorak layout on my keyboard was mucking things up!

    It is great to be playing emulators on my iMac with the Wiimote! :)
     
  19. smoshanthony macrumors newbie

    Joined:
    Sep 6, 2010
    #19
    Thank you! Spent a few hours looking for a solution until I came here :)
     
  20. BeeEss macrumors newbie

    Joined:
    Sep 27, 2010
    #20
    FWIW, I couldn't get the patched version to work at first - every Wiimote button press, no matter what it was assigned, returned the letter A. I noticed that I had VMware Fusion running, so I quit Fusion, tried it again, and it worked perfectly. Not sure if Fusion does anything funky to the keypresses, but I thought I'd pass this along just in case.

    --b
     
  21. trent0n macrumors newbie

    Joined:
    Feb 21, 2011
    #21
    so Ive been trying for a few hours now to get this to work with dolphin ( a Wii and gamecube emulator) playing smash bros. melee ( <--- a gamecube game)....

    its crazy, my wiimote works with every application everywhere BUT dolphin. my head is spinning on this i guess dolphin just doesnt work with the wiimote when your playing gamecube games....anyone ever get this to work?

    anyways...I'm just going to get Super Smash Bros. Brawl wich is a Wii game and then i can use my Wiimote (hopefully) and if not ill go buy a damn usb gamepad or something.
     

Share This Page