Dashboard Trouble: Can't Access Widget Preferences

Discussion in 'Mac Basics and Help' started by Ledgem, Nov 5, 2009.

  1. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #1
    Hello everyone,

    I'm having some problems with the Dashboard. I don't recall having these issues with 10.6.0; I don't know if they happened immediately following an update to 10.6.1. I noticed the issue immediately after installing an updated widget, Delivery Status, but to be honest I can't say whether that was exactly when the problematic behavior started or whether it was the first time in a while that I attempted to access a widget's preference pane.

    I've Googled around and searched these forums. The common advice is to delete com.apple.dashboard.plist (and com.apple.dashboard.client.plist, for good measure) from your user/library/preferences folder. I did both, and while my Dashboard reset to what it looks like on a fresh system, the problem persisted.

    Here's the problem: clicking on the "i" on any widget that offers it does nothing. Ordinarily the widget would flip around and offer you some preferences when that's clicked. Some other behaviors that may be worth noting:
    If the "i" is clicked, clicking and dragging the widget will cause the widget to "jump" such that the widget is being dragged by the area where the "i" is located. For example, on the weather widget, the "i" is located on the lower right; if I click it, then move my mouse and begin clicking and dragging that widget from the upper left corner, the widget will jump such that suddenly the lower right hand corner is where the pointer is.

    Ordinarily, clicking on a non-widget will cause the Dashboard to disappear. If a widget's "i" is clicked, non-widget space must be clicked twice in order for the Dashboard to disappear.

    No errors are visible in the Console. If I log in to my Administrator account, the Dashboard works perfectly fine; this problem seems limited to my Standard (and regularly-used) account.

    Possible solutions I've tried:
    1) Deleting the dashboard and dashboard.client plists from both my standard and administrator accounts. I deleted the files on one account and, without opening the dashboard, logged out, deleted them from the other, logged out, and logged back in to my regular account. The problem was not fixed.

    2) Using the utility "Yasu" to clear all system caches. This didn't have an effect.

    3) I booted from the Snow Leopard DVD and reinstalled Snow Leopard. While the installer took a while, I don't know exactly what files it replaced - the system still claimed it was at 10.6.1 (which is expected, based on Apple's advertised new features for Snow Leopard). More importantly, it didn't fix the problem at all.

    4) Of course, I've tried permissions repairs multiple times and it had no effect.


    This issue makes the dashboard much less useful. I'm very close to last-resort measures of formatting the system drive and then reinstalling fresh. (That sounds worse than it is - assuming my Time Machine volume doesn't suffer a problem, recovering all of my settings and files is done easily and painlessly enough. What a fantastic feature, although if the problem restores along with it...) Given that it only affects on user account and not another, it seems like there's something specific...

    Does anyone have any ideas for how I can fix this, short of reinstalling the whole system?

    I am using OS X 10.6.1 (upgraded from 10.5.8 to 10.6.0, then updated to 10.6.1) on a Macbook Pro 4,1.

    Thank you for reading and for any suggestions you may have!
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    skimmed over your post...

    I don't see where you say you've tried another user account. Worth a shot?
     
  3. jlytes31 macrumors newbie

    Joined:
    Feb 27, 2011
    #3
    Tried new account...

    Sorry for reviving an old thread. Ledgem had it described perfectly. I am having the same situation, unable to use widget preferences.

    I tried the same steps Ledgem used in his post. I also created a new account based of Gregg22's suggestion. This account has a dashboard that works the way it should. Any suggestions as to why a new account would work but the old one wouldn't? I really don't want to have to create a new account just for the dashboard.

    Thanks for your help!
     
  4. Ledgem thread starter macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #4
    Wow, old thread indeed! I'm sorry for not coming back here and updating with what I ended up doing - I did it on the Apple forums, but forgot about my post here, it seems.

    In addition to the things that I wrote in my original post, I tried to delete everything, install Snow Leopard fresh, and restore from my Time Machine backup. That didn't fix the issue. I'm sure it's an issue with a file or two, but I couldn't narrow it down, and realized that I'd save time if I just nuked my old account and made a new one. Here's what I wrote for how I resolved the problem:

    I resolved the issue by creating a new user account. I drew inspiration from this guide that explains how to create a new account and migrate to it: http://reviews.cnet.com/8301-13727_7-10386342-263.html

    In my case I did things a little differently. First I backed up my entire drive to an external using SuperDuper. I then logged into my administrator account (you can just create a second account and log into that) and deleted my primary account - the one with the widget problem. I chose to delete the home directory. I then re-created the account.

    I logged into the account and then opened my backup disk image, and began copying files back over. The most arduous part of the process is copying over your Library files, because unlike the Documents, Music, Downloads, etc. folders, the Library folder contains data and it can't all be overwritten (not as long as you're logged in to that account, anyway - although if you perfectly overwrote it, perhaps the widget problem would return). I manually copied over as much as I could, and avoided much of the com.apple plist files, as the system tended to claim that I couldn't overwrite those due to their being in use.

    After all that (~4 hours, perhaps three of which was waiting on data transfers) and some minor adjustments to the System Preferences, my widgets are still working even after rebooting and I wouldn't know that I'd done anything with the user account. There are likely still some programs that need additional tinkering (iChat seems to have forgotten my stored passwords, for example), but overall this wasn't as bad as having to redo a Windows install.

    Hope it helps anyone else who comes across this issue. There's probably a file or two that just needs to be removed, and going through this user account business is a bit of a brute force method, but... it works. Takes a bit of time, but it's not that bad a procedure. Good luck.


    It seems like a big hassle and it can be a little scary to perform, but it's actually not too bad. For what it's worth, I'd forgotten that I even went through that... but I still remember almost each time that I had to redo my Windows installations :)
     
  5. jlytes31 macrumors newbie

    Joined:
    Feb 27, 2011
    #5
    Thank you for the quick reply!

    Surprised there wasn't more info on the problem!

    Not what I want to do but if it gets it taken care of it looks like that is whats going to happen!

    Thank you for all of the info! I will try later tonight!
     

Share This Page