Dashcode iphone simulator on Powerbook G4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Ignorant, Mar 18, 2009.

  1. Ignorant macrumors newbie

    Joined:
    Mar 18, 2009
    #1
    I run Dashcods on my PowerBook G4 PC Mac. When I run I do not see the iphone simulator. Will the simulator not run on PC Mac? I know this is an ignorant question, but I am ignorant.
     
  2. SilentPanda Moderator emeritus

    SilentPanda

    Joined:
    Oct 8, 2002
    Location:
    The Bamboo Forest
    #2
    I believe you have to have an Intel Mac. A Powerbook G4 is not.
     
  3. Ignorant thread starter macrumors newbie

    Joined:
    Mar 18, 2009
    #3
    Thanks

    Really, I suspected that the iphone simulator would not work on my Powerbook G4. I should have done more homework. I can run Dashcode, and when I "run" the simulation , a box does come up. It just does not look like the iphone. Oh well, so sad.
     
  4. recombinant macrumors newbie

    Joined:
    May 19, 2010
    #4
    OK I just had this same problem in which the iPad simulator gets launched instead of the iPhone...

    I solved this issue by switching the target OS in Dashcode to OS 3.1.3 instead of 3.2:

    Debug --> Run Settings --> Simulator - iPhone 3.1.3

    ...then when i run the application, the simulator launched using the iPhone instead of the iPad.

    Unfortunately Dashcode didn't persist the setting so it looks like I'll have to switch it when i launch Dashcode each time. Hopefullly they'll fix that along with the "defaulting to iPad" in the simulator.

    HTH.
     

Share This Page