Dashcode on Mavericks

Discussion in 'OS X Mavericks (10.9)' started by iJC-1976, Sep 25, 2013.

  1. iJC-1976 macrumors member

    iJC-1976

    Joined:
    Jun 16, 2010
    Location:
    Seattle WA
    #1
    Has anyone been able to get Dashcode 3.0.5 working on Mavericks? I get the following error message when I try to launch it: "You can't use this version of the application "Dashcode.app" with this version of OS X" I have no idea how to get it to work. :confused:
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    contact whoever makes the app - they should have an updated version.
     
  3. iJC-1976, Sep 26, 2013
    Last edited: Sep 26, 2013

    iJC-1976 thread starter macrumors member

    iJC-1976

    Joined:
    Jun 16, 2010
    Location:
    Seattle WA
    #3
    Thanks, but that really doesn't help me. Dashcode is or was part of Xcode so it's an Apple product. Normally you can download a new version od Dashcode when you update to the newest version of Xcode. I Tried to do this but the newest version 3.0.5 doesn't work with Mavericks. I was wondering if anyone knows of any tweaks I could use to get it working. I did discover that I can run it using terminal but that isn't really how I would prefer to have to launch it every time I want to code a widget or web app.
     
  4. iJC-1976 thread starter macrumors member

    iJC-1976

    Joined:
    Jun 16, 2010
    Location:
    Seattle WA
    #4
    Still trying to get help here.....

    So like I said before I can get Dashcode to run through Terminal but I would rather have it run normally with iOS 7 graphics to choose from but it's not a deal breaker if we can't do that. I'd settle for the app to just let me launch it. Anyway, I get this error message when I launch it with Terminal:

    2013-09-26 15:58:36.256 Dashcode[2073:507] *** WARNING: -[NSImage compositeToPoint:fromRect:eek:peration:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:eek:peration:fraction:] instead.

    Does this mean anything to anyone on here?
     
  5. Todd328 macrumors newbie

    Joined:
    Mar 7, 2006
    Location:
    Athens GA
    #5
    Same here...

    Yes. I'm getting the same message. Has Apple not released an updated version of Dashcode for Mavericks yet? Will they ever???




     
  6. md11 macrumors member

    Joined:
    Jul 26, 2005
    Location:
    Europe
    #6
    Still nothing.
    By the way I'm stuck with signing widgets to pass gatekeeper. Are you able to do this?
     

Share This Page