iPhone Data Connection is Flaky after Jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by TypeMRT, Feb 12, 2013.

  1. TypeMRT, Feb 12, 2013
    Last edited: Feb 12, 2013

    TypeMRT macrumors 6502

    Joined:
    Sep 7, 2007
    #1
    I'm using an iPhone 5 on AT&T and ever since the jailbreak my data connection has been dropping randomly. I hope it's not 3G Unrestrictor.
    Anyone else having their data connection drop randomly? I might try My3G instead.
     
  2. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #2
    I was close to restoring back to stock tonight for this reason. My LTE has just stopped working several times since jailbreaking. Toggling it off and back I usually fixes it. I've also noticed pictures/websites not loading fully also. Irritating but not enough to make me ditch all of the amazing new tweaks I've found recently.
     
  3. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #3
    I've noticed this as well on my 4S on AT&T. I also have 3G Unrestrictor installed. Is this a known problem?
     
  4. tateu macrumors 6502

    Joined:
    Jan 27, 2012
    #4
    Last night, while jailbroken on an AT&T 4S running IOS 6.1 with WiFi off, I lost 37% of my battery in 6 hours while I was asleep. That seemed excessive and since there are rumors of a 3G issue for the 4S on IOS 6.1 I took the plunge and restored to IOS 6.1.1 this morning.

    I have not re-jailbroken yet but I have seen the issue described by the posters above: with WiFi disconnected and data on, I have occasionally been unable to connect to the internet until I toggle airplane mode off and on. I have had this issue pretty much since day one with this 4S, and have seen it while jailbroken too.
     
  5. Hustler macrumors 6502

    Hustler

    Joined:
    May 31, 2010
    #5
    Ip5 AT&T JB 6.1 also have spotty data here. I can still place a call but when I update a web page, it never loads. When I toggle airplane on off it works.

    ----------

    Also I do not have 3G restrictor
     
  6. dinggus macrumors 65816

    Joined:
    Jan 17, 2012
    #6
    I leave WiFi and Bluetooth on and don't notice a battery drain. If I leave it on during I sleep, I probably lose 5-10% of my battery life.

    Was the update to iOS 6.1.1 worth it?
     
  7. tateu macrumors 6502

    Joined:
    Jan 27, 2012
    #7
    I normally leave WiFi and bluetooth on too, I just turned it off last night because I heard there was an issue with the 4S and 3G and wanted to test it. With Wifi on, I normally only lose 5-10% while I am alseep.

    So far, 3G for IOS 6.1.1 on my stock AT&T 4S doesn't look any better. I've lost 14% in 2.5 hours with 49 minutes of usage. And I actually have not used my phone at all. It has been asleep this entire time with 3 email accounts set to fetch every 15 minutes and two email accounts set up as Exchange/Hotmail and set to push. I've received three emails in that time.
     
  8. tateu macrumors 6502

    Joined:
    Jan 27, 2012
    #8
    And to quote myself because I've had these types of problems when my phone is not jailbroken:
    That page you linked to is there more for legal reasons than anything else. It's so they are not liable if anything does go wrong with jailbroken phone.
     
  9. TypeMRT thread starter macrumors 6502

    Joined:
    Sep 7, 2007
    #9
    Last night I turned off WiFi and went to sleep. After 6 hours the battery dropped 20%. I have 2 email accounts set to push and only received 3 emails during that time.
    I've uninstalled 3G Unrestrictor to see what happens during a normal day without it.
     
  10. TypeMRT thread starter macrumors 6502

    Joined:
    Sep 7, 2007
    #10
    No luck. It randomly bounces between LTE, 4G, voice only, & No Service.
     
  11. TypeMRT thread starter macrumors 6502

    Joined:
    Sep 7, 2007
    #11
    Today I turned off the Enable LTE toggle and my data connection has been much, much better.
     

Share This Page