Data loss (Disk Utility Disk repair made volume unbootable)

Discussion in 'macOS' started by studio81, Sep 27, 2016.

  1. studio81, Sep 27, 2016
    Last edited: Sep 27, 2016

    studio81 macrumors member

    Joined:
    Jan 6, 2010
    #1
    I really hope someone can help.

    My sisters MacBook Pro started playing up (general slowness and constantly hanging). I tried a few things, deleting unneeded files, checking the SMART status, making sure the RAM was recognised and tried a verify disk in Disk Utility. It produced an error (sorry I can't recall, probably because I was booted into the OS) which led me to instructions to boot into single user mode and run something like: /sbin/fsck -fy

    This returned an error along the lines of "The volume could not be repaired.", even after several attempts. Upon trying to boot, it was no longer finding the disk/OS. In a panic, I physically removed the disk from the computer to back it up, thinking the drive was failing but plugging it into my computer via a USB/SATA cable, the drive would not mount, I think it asked me if I wanted to initialize it. I can't believe it was slow yet working and I've borked it trying to fix it!

    My thinking was the data was still on the drive but I've somehow messed up the volume/directory structure. Further googling led me to a tool called Disk Warrior. To be honest I should have treaded more carefully and fully understood what it was doing but I chose the rebuild option and it did its thing.

    Now instead of a having a disk with the old data back (about 220GB of a 250GB drive) with the usual Applications, Library, System, Users folders, I've got:
    • Rescued Items (14GB)
      • Missing Folder 1
      • Missing Folder 2
      • Missing Folder 3
      • etc
    • bin (4MB)
    • sbin (2MB)
    • dev (0 bytes)
    I'm not entirely computer illiterate but I've no idea what I've done or what to do next and why Disk Warrior didn't save me. Can anyone make any suggestions (short of paying to have the data recovered professionally)?

    P.S. The computer is now running fine with an SSD installed, I'm just trying to get the data back now!
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
  3. studio81 thread starter macrumors member

    Joined:
    Jan 6, 2010
    #3
    Thanks JohnDS - you know as soon as I got that first error message I knew I had goofed up!

    I will try DataRescue - I'm hoping the files should still be there somewhere
     
  4. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #4
    I assume your sister wasn't doing Time Machine backups?
     
  5. studio81 thread starter macrumors member

    Joined:
    Jan 6, 2010
  6. RumorzGuy macrumors 6502

    RumorzGuy

    Joined:
    Sep 17, 2008
    Location:
    Guam, Mariana Islands, U.S.A.
    #6
    Just some general advice for all, which has been shared so many times before . . .

    Whether you use Time Machine, Carbon Copy Cloner, Superduper, or something else, full backups to an external drive or partition should be a daily habit if you are doing important work on your machine, or at least every few days if it is just a "fun machine".

    You just never know when something might go wrong, and you don't want to be caught with your proverbial pants down.

    As has already been noted, a full backup just prior to serious maintenance work is an absolute must . . . or be prepared to pay the consequences for your shortsightedness and impatience.

    I hope you are able to restore your data.
     
  7. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #7
    OP (if you're still checking this thread):

    Your posts above aren't really clear.
    What is your situation (with sister's Mac) now?

    It has a NEW SSD in it, is this correct?
    Booting and running ok?

    And the OLD drive (the one with the problems) -- where is it now?
    Do you have it "in hand", as a "bare" drive?

    What to do next:
    Get either a:
    - USB3 enclosure
    - USB3/SATA docking station
    - USB3/SATA "dongle adapter"

    Put the OLD drive into the above and connect it to your sister's Mac.

    Does it mount on the desktop?

    If so, you may need to do this next:
    1. Click ONE TIME on the drive to select it
    2. Type "command-i" (eye) to bring up the get info box
    3. At the bottom, click the lock and enter YOUR SISTER's password (NOT yours)
    4. At the bottom, put a checkmark into box "ignore ownership on this volume"

    WHY you did the above:
    This now permits items on the old drive to be freely copied to the sister's NEW drive without permissions problems.

    Can you now go into the "users" folder, open your sister's home folder, and "get inside"?
    Can you see other folders and files she might have saved with her stuff in them?
     
  8. studio81 thread starter macrumors member

    Joined:
    Jan 6, 2010
    #8
    My sisters mac has a new SSD in it with a fresh OS install as the old drive could not be used to boot into. I removed it to see if I could access it externally (maybe it wasn't bootable but could still be mounted) but it wouldn't mount. Disk Warrior was then used to recover the directory as my assumption was the "Repair disk" function in Disk Utility (and the command line equivalent of /sbin/fsck -fy) had corrupted the directory but the data was still there. Disk Warrior did it's thing but whatever it's done, it didn't work and I'm now left with a few "recovered" files but not everything by a long shot.

    My understanding of Disk Warrior was it would repair the directory and the disk could then be easily mounted, or put back into the computer and booted, essentially getting me back to where I had started but whatever way it functions is not what I expected.
     
  9. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #9
    Studio wrote:
    "Disk Warrior did it's thing but whatever it's done, it didn't work and I'm now left with a few "recovered" files but not everything by a long shot."

    The drive may be suffering from:
    a. hardware failure (intermittent)
    b. software corruption
    c. both.
    (if it's hardware failure, no software is going to help)

    Be aware that DiskWarrior is a "one trick pony", designed to do ONLY ONE thing. That is to repair corrupted disk directories. If the problems are elsewhere, DW can't help.

    At this point, I would try downloading "DataRescue3" (may be version 4 by now), and try that on the drive.
    It's a free download.

    DR is DATA RECOVERY software.
    In "free mode", it will scan the problem drive and report back what it finds.
    It will let you recover -ONE- file (and one file only).
    The purpose of getting this far is to see if the app will work for you before you pay the registration fee.
    If you see a long list of potentially recoverable files, it might be worth paying the fee, getting the code, and then letting DR "go to work" on the drive for you.
    IMPORTANT: You WILL need a SECOND drive to serve as the "scratch/recovery" volume.

    If DR does nothing (perhaps it won't be able to "see" the drive to "get at" it), I have another trick that I've used successfully when nothing else would work.
    That is:
    a. re-intialize the drive. DO NOT do a "secure erase" -- just a quick re-initialization. The directory is replaced with a good one, but the sectors of the drive are left untouched (with the old data STILL THERE)
    b. now it mounts again, but "looks empty"
    c. NOW run Data Rescue on it
    d. DR will ignore the directory (which shows an "empty" drive) and go "right to the platters".
    e. DR may now be able to scavenge the old data and re-assemble it.
    f. BE AWARE that you will probably lose all previous folder and file names. Par for the course with data recovery.

    Final thought:
    Advise your sister of something called "backing up your drive".
    Will save a lot of pain in the future...
     

Share This Page