Data Usage Has Quadrupled since upgrading to Mavericks!

Discussion in 'OS X Mavericks (10.9)' started by rochow, Jan 23, 2014.

  1. rochow macrumors member

    Joined:
    Aug 20, 2013
    #1
    Data usage for the last 6 months: http://postimg.org/image/flylwb1pv/

    I think I've FINALLY figured out what the hell is going on last night, I have been racking my brain for a few months now.

    End of October is when I installed Mavericks! Ever since then, the data has been smashed. If the computer is off, no usage happens aside from a few meg from my phone on wifi. When the computer is on, all I'm doing is web work as I've been doing for years & years & years (2GB a day tops).

    How in the world this much data is being used is beyond me.
    And it has to be just data, because it's not like I have a terabyte hard drive on the computer where it's all accumulating :)

    Only two applications I've installed since Mountain Lion, maybe around then I can't remember exactly:
    - Avast
    - Photoshop CC

    They appear to be the 3 possible culprits. Possibly something has **** itself, and is just on an endless download loop trying to complete?

    I installed Little Snitch, nothing seemed out of the ordinary with access requests, although a virus is possible it's unlikely.

    Any ideas? Is activity monitor 100% accurate at capturing all in & out, and over what timeframe (it'll capture from when it's opened til when it closes?)
     
  2. kissmo macrumors 6502a

    Joined:
    Jun 29, 2011
    Location:
    Budapest, Hungary
    #2
    Mate.
    I thought it's me who is experiencing this only.
    I have a 64 GB SSD.

    After a while I start to see GBs dissapearing from free space for no reason.
    I did clean installs, I tried beta versions, still the same.

    Some data seems to be gone.
    I downloaded iWork update and iMovie update today and now I see a drop in 2 GB per total.
    I assume some code was added to the apps. However 2 GB seems a lot.

    I had 26 GB free 1 month ago. I installed NOTHING and freespace dropped at 18.
    Then I make the update and I have now 15.6 GB free.

    I have Trim Enabled.
    No clue what is going wrong.
     
  3. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #4
    If you are unsure that Activity Monitor is recording everything, you can try using nettop in a Terminal. Once its running, hit c to collapse the connection details to a per-process summary. Leave it running and it will log all network activity.
     
  4. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #5
    One thing to check is iCloud--especially photo streams to iPhoto.
     
  5. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #6
    Time Machine local backups are stored locally on your computer. You can disable local backups. For an SSD that small, I'd say it's pretty critical that you do.
     
  6. rochow thread starter macrumors member

    Joined:
    Aug 20, 2013
    #7
    Might be the storeagent has **** itself. Within half hour or so, it was up to 2GB of usage.

    However, "installed in the last 30 days" shows just 4 updates. No way that could have used 250GB of data unless it is failing for some reason & continuously looping.

    Leaving nettop open to see if anything else happens, or storeagent has been the problem.
     
  7. powerstrokin macrumors 6502a

    powerstrokin

    Joined:
    May 18, 2013
    #8
    This is an issue for me as well. We have satellite internet through Dish Network (DishNet/ Hughes Net... horrible, story for another time.) and thus are capped at a measly 15GB per month. I came from having Comcast with no cap so I need this thing to stop using bandwidth whenever it wants.

    I was informed about updates in the App Store yesterday, so I opened App Store to see what they were. I knew I wasn't going to download them over the internet here at home and would venture to town to tether to my phone. (Unlimited LTE on Sprint)

    What I didn't know was that just by merely opening App Store, it would begin downloading the updates. I HAVE AUTOMATIC DOWNLOADS/ UPDATES TURNED OFF! It was downloading in the background and did not show status bars for downloading these updates to iWork suite.

    I have now turned off the only 'on' feature relating to updates- the option to even notify me of updates. I am scared to even open the App Store now because it seems like it will want to start downloading something in the background.

    I really wouldn't care at all if I didn't have this completely crummy and money grab of an ISP, but I live in the middle of nowhere and it literally is the only option for Internet.
     
  8. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #9
  9. rochow thread starter macrumors member

    Joined:
    Aug 20, 2013
    #10
    Mine had only used 54kb so pretty good. I'll known in a few days if that was the problem, somehow it takes 48 hrs for the ISP usage page to get updated :confused:.
     
  10. benoitgphoto macrumors 6502

    Joined:
    Jul 19, 2007
    #11
    This solution fixes the problem...go for it. I posted about that about a month ago.
     
  11. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #12
    And it will introduce a new problem: it won't check if a certificate is still valid or not. You will be susceptible to thing we've seen with the DigiNotar hack. Their root certificate got compromised and was used for malicious websites. It was used to spy on the Iranians by their own regime in order to track down people who were against the regime. Since the certificates where seen as valid by browsers such as Safari no alarm bells went off. The DigiNotar certificate was revoked when they discovered this. A revoked root certificate will cause alarm bells to go off (it will trigger a warning about the certificate of a website). However, the browser or OS (as in this case) needs to check if a certificate is revoked or not. If you turn of the OCSP settings it won't do these checks and thus will not be able to detect a revoked certificate and warn you about it. This leaves you vulnerable to attacks.

    People who live in regimes like the one in Iran are better off moving back to Mountain Lion than disabling the OCSP settings.

    In this case it is very crucial to understand what you are disabling!
     
  12. rochow thread starter macrumors member

    Joined:
    Aug 20, 2013
    #13
    I've had no problems with OCSPD that I can see, data is very minimal.

    Despite turning off storeagent there is a new task now, "kernal_task.0" that has used 7.5 GB of data in one day :(

    Beyond frustrating. However, does nettop track all data - aka, even internal network? If so, then it could be transfer from my computer to the NAS. I did try transferring some files purely to see if it'd increase but it's actually disappeared from the list now. Everything else is still there with all the figures. Weird.

    I'll know tomorrow as I barely used the computer at all, should be well under a gig of usage unless kernal_task was indeed doing external data.
     

    Attached Files:

  13. rochow thread starter macrumors member

    Joined:
    Aug 20, 2013
    #14
    As a follow up this does appear to have solved the problem. Time will tell for sure.

    storeagent (aka, App Store) must have some kind of bug where it can loop, as there is certainly not 250GB of updates a month to download! Make sure to disable automatic updates if you have any data usage problem as it may be it.

    You can use nettop as mentioned above and leave it running for a few hours to a day, to see all processes on the computer using the network traffic. There are some other things that can be to blame, for me this was it.

    Thanks guys!
     
  14. kissmo macrumors 6502a

    Joined:
    Jun 29, 2011
    Location:
    Budapest, Hungary
    #15
    Thanks. I will try.

    After you disable them is it possible to clean them?
     
  15. Candlelight macrumors 6502a

    Candlelight

    Joined:
    Oct 12, 2011
    Location:
    New Zealand
    #16
    I've just discovered this affects me today as well. Have knackered the certs so hopefully that fixes it.
     

Share This Page