Date format

Discussion in 'macOS' started by KeithJaw, Sep 3, 2010.

  1. KeithJaw macrumors newbie

    Joined:
    Sep 3, 2010
    #1
    I've recently installed 'Snow Leopard'.

    In 'Finder' the date displays the way I want (UK: day/month/year), and says 'Today' or 'Yesterday' when appropriate.

    But in the 'Open' dialogue, the date displays in US format (month/day/year), and doesn't do the 'Today' thing.

    This is very confusing.

    Anyone know how to fix it?


    KEITH.
     
  2. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    I'm likely being dense, but what is the "Open dialogue"?
     
  3. KeithJaw thread starter macrumors newbie

    Joined:
    Sep 3, 2010
    #3
    By the 'Open' Dialogue, I mean, when you go to open a file, and 'finder' comes up to enable you to browse through your files.
     
  4. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
  5. KeithJaw thread starter macrumors newbie

    Joined:
    Sep 3, 2010
    #5
    Yeah, this is where I set my date preference, which I get in 'Finder'.

    But where do I set it so that it shows correctly in an 'Open' dialogue?
     
  6. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #6
    OK, I have no idea what you mean. So I'll just follow the thread until the lightbulb goes off for me. This is something built into OS X, not some add-on?

    When I make the change in System Prefs, the format seems correctly changed everywhere I look. But obviously I'm missing something.
     
  7. FourCandles macrumors 6502a

    Joined:
    Feb 10, 2009
    Location:
    England
    #7
    Which applications are you using in order to open a file? And do those apps have date format preferences?
     
  8. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #8
    Thanks. I think the light bulb has now lit. This is presumably some non-Apple application that doesn't use the standard approach.
     
  9. KeithJaw thread starter macrumors newbie

    Joined:
    Sep 3, 2010
    #9
    No, this has nothing to do with some strange application.

    Just Snow Leopard - straight out of the box.

    Compare these 3 screenshots:

    1. The 'open file' dialogue: look in the 'Preview' column. The date shows in American format, and never says 'Today' (it used to in OSX 10.4)
    2. 'Open file' dialogue, in listed format: Date shows the way I want it.
    3. 'Finder' dialogue, listed format: Even better: date shows in 'long format'.

    Why are they all different? How can I make them the same?
     

    Attached Files:

  10. mooblie macrumors 6502

    mooblie

    Joined:
    Apr 23, 2009
    Location:
    The Highlands, Scotland
    #10
    Regarding attachment two (the "Open" dialogue) above: if you make the Date Modified column WIDER, it will show the long date format?

    ...and... I DO get relative dates, in UK format as well, in the Preview Information pane. ??
     
  11. dwero macrumors newbie

    Joined:
    May 19, 2010
    #11
    :D sometimes you have to restart to makesure its update.
     
  12. KeithJaw thread starter macrumors newbie

    Joined:
    Sep 3, 2010
    #12
    Hey, Mooblie, that worked!

    But my main problem is how do I get the date format to the UK standard in attachment no. 1?
     
  13. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #13
    The first appears to be generated not by OS X directly but by Microsoft Word. Note the "Open: Microsoft Word" that titles the window. What happens if you open TextEdit and use its File-->Open... to preview that same file? I bet you get the format you want. I think this is a Microsoft Office issue, which I'll leave to others to help you with (since I don't know how).
     
  14. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #14
    I'm getting the same behaviour from Word, but not from TextEdit. I think LPZ is correct; Word is doing something non-standard.
     
  15. KeithJaw thread starter macrumors newbie

    Joined:
    Sep 3, 2010
    #15
    Interesting - I tried TextEdit and, as you say, all is well.

    But it's not just Word. All my Office applications do it (as I suppose you'd expect), but also Archicad, which is the other major application that I use.
    And it didn't happen under OSX 10.4.
     
  16. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #16
    You're right. Haven't found a non-Apple app that respects that date format setting. I wonder if there is one ...
     
  17. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #17
    OpenOffice seems to respect my own date format settings (yay open source) along with others Non-Apple apps like Firefox and BBEdit. In the Office apps, are the preferences of localization set for your area? It may make a difference. I don't have any of the apps mentioned that aren't working correctly for you to try on.
     
  18. KeithJaw thread starter macrumors newbie

    Joined:
    Sep 3, 2010
  19. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #19
    No. Maybe a bug in MS Office and Archicad though.
     
  20. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #20
    So if you do File-->Open File... in Firefox and then select a file (in Column view) the date format is correct in the Preview window? Did you set some preference in Firefox to get this? It doesn't work for me.
     
  21. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #21
    I use list view, which shows it correct. Column view shows a different format though. BBEdit shows the correct format in column view though.
     
  22. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #22
    I'm not so sure. For example, OpenOffice does indeed correctly set the locale in its preferences based on my System Preferences format setting. But the date is still displayed incorrectly if I do File-->Open and look at the preview.

    This seems to be either a bug in OS X, or very few developers know the "right" way to do something.
     
  23. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #23
    Yes, I see that now for Firefox. Don't have BBEdit, but it's good to know that there's some app for which all the views are correct.

    Thanks.
     
  24. KeithJaw thread starter macrumors newbie

    Joined:
    Sep 3, 2010
    #24
    My point is that all these applications behaved correctly until the introduction of Snow Leopard, although interestingly enough I notice that it doesn't happen with the new release of Archicad, which needs Snow Leopard to run.

    If it weren't for that, I would gladly remove S.L. off our system, since this is only one of about different 6 ways in which this upgrade has disrupted our work flow.
     
  25. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #25
    I tested in Google Chrome, MacVim, and VLC and all showed correct date formats, but Camino 2.0.4 did not. This leads me to believe that something small changed in Snow Leopard that causes the developers to need to change some small thing for this to work right. I don't see this as a bug in SL, but rather applications still catching up to Snow Leopard's differences. Firefox, Camino, and Chmox so far are the only ones not displaying the format correctly, among apps I've checked on my machine.
     

Share This Page