DD-WRT bridge/share with Airport Express

Discussion in 'Mac Basics and Help' started by horix, Jul 19, 2009.

  1. horix macrumors newbie

    Joined:
    Jul 19, 2009
    #1
    Here is a picture of what I'm trying to do:
    http://tinypic.com/r/160x3lf/3

    I know this is possible, but for the life of me I can't find the correct thread to walk me through it.

    I want to WIRE my Airport Express to my WRT54G (which is running DD-WRT of course >.<) and have them share the workload on my network. I have a lot of roommates and the WRT54G just can't handle the stress anymore. I need to increase my maximum port number without sacrificing bandwidth.

    When I search google I keep getting the unwired/WDS settings setup which I DO NOT WANT (WDS cuts the main routers bandwidth in half!)

    So yeah, hopefully somebody can help me out or point me in the direction of a thread that has this wired solution.
     
  2. horix thread starter macrumors newbie

    Joined:
    Jul 19, 2009
    #2
    Got It!

    Well it was a lot easier than I thought.

    For those of you who want a reference I followed an ancient thread I found here:

    http://rgbdream.com/?p=44

    I improvised a lot, since the menus they lead you through on the Airport Express are WAY outdated. Mac has made this MUCH easier in recent firmware updates, so don't over think it like I did. Also, don't use WEP as they say too...as I'm sure most know it can be hacked in under 5 seconds >.<

    I used WPA-Personal, but I'm going to try and update it to WPA2 and see if it continues running smoothly. Also, on the password part, even though it's WPA you should STILL place a $ symbol before the password!

    Under the internet tab, you will NOT have the options they list for steps 1 through 3. Instead for that section do the following:

    1. You will not see the option they list (Connect Using>AirPort (WDS)) so instead use the "Ethernet" option.
    2. There is NO section I can find that allows for MAC address input so just skip this step.
    3. Again, I couldn't find the checkbox it talks about ("Also allow wireless client computers") so just skip this step as well.
    4. Set “Configure” to “Using DHCP” (this should already be selected)

    The next unnumbered directions are also outdated, so skip them as well. Update the new settings and hopefully your airport will be green and under one single SSID network.
     

Share This Page