De-interlacing? Final Cut Express? iMovie? Canon HV-10

Discussion in 'Digital Video' started by JHacker, Jun 21, 2007.

  1. JHacker macrumors 6502

    JHacker

    Joined:
    Aug 27, 2006
    Location:
    East Coast
    #1
    When trying to export from my Canon HV10 to a nice sized high quality HD movie from iMovie, the picture stutters very often, it's not clean, smooth, and crisp.

    I read that because the camera is 1080i, I need to de-interlace when exporting. I tried this in iMovie, but it didn't help. But then I also read that iMovie's de-interlacing doesn't work, so that would explain it.

    Is everything I said so far correct? And would Final Cut Express be able to fix this problem easily and let me export smaller but actually nice looking videos?
     
  2. banjomamo macrumors regular

    Joined:
    May 9, 2006
    Location:
    USA
    #2
    Im not sure about iMovie since I have only used Final Cut Pro, but I know you can deinterlace footage on the pro stuff. How are you capturing your footage? Over firewire? If you use a different frame rate (24) I am pretty sure that shoots and captures as progressive at 1080.
     
  3. Peel macrumors 6502a

    Peel

    Joined:
    Aug 30, 2004
    Location:
    Seattle
    #3
    I may be wrong here, but I'm pretty sure that the HV-10 doesn't shoot 24p, you need the HV-20 for that.

    Edit: Nope, I'm not wrong. Just checked the specs; it only shoots in 1080i, no p of any kind.
     
  4. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #4
    About the deinterlacing:

    When you say "deinterlace when exporting," are you talking about exporting back to tape to watch on your TV, or exporting to a file to, say, put on the web?

    You shouldn't have to deinterlace your footage if you're putting it back onto tape in the same format as the original (1080i60). If you're converting it to standard definition, then you might run in to trouble because the field order is switched, which would indeed cause stuttering during motion. I don't know for sure, but it seems like iMovie should be smart enough to shift the fields for you so you wouldn't have to worry about it.

    If you're exporting to a file, then deinterlacing will not solve your stuttering problem. Usually, when I render interlaced HD to a file for web or progressive SD, the dimensions I use for the video are small enough that the fields naturally blend together during the resampling and disappear.

    So basically, deinterlacing should be unnecessary no matter what you're doing. But the only thing it might help is if you're converting it to SD to watch on your TV screen.

    If it is the HD to SD issue, I wouldn't even recommend solving it by deinterlacing. Final Cut (Pro, at least) has a filter that will shift your fields for you, so you can still have an interlaced SD video.

    Otherwise, I'd say it's an issue with what format/compression you're using. Am I correct in assuming that everything looks fine when you play it back in iMovie during editing?
     
  5. banjomamo macrumors regular

    Joined:
    May 9, 2006
    Location:
    USA
    #5
    you are exactly right. i read that wrong - sorry everyone. and thanks for correcting me.
     
  6. JHacker thread starter macrumors 6502

    JHacker

    Joined:
    Aug 27, 2006
    Location:
    East Coast
    #6
    I'm not recording it back to tape, I'm creating a file on my computer. It looks perfect in iMovie and I've put it on my computer through Firewire. I want the exported video file to look just like the file in iMovie, but be smaller in size.

    I wouldn't really call it a stutter, I didnt' know how to describe it before. It's kind of like white-ish lines appear for a second on the picture? And make it not smooth like it plays in iMovie? I thought this was what de-interlacing would fix?

    There's obviously a way for me to create smaller .mov or .mp4 files that look as solid as the movie does in iMovie - and I've tried all sorts of export settings. But I just can't get it to work.

    Are you sure de-interlacing in Final Cut Express wouldn't be different?
     
  7. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #7
    Are you able to post a screenshot of the white-ish lines? It sounds interesting. :)
     
  8. gokuu macrumors member

    Joined:
    May 12, 2007
    #8
    i have had this problem before and what i did, was simply re-capture it and then it was gone, but i did capture it in final cut express......but i did see the lines you are talking about...DO NOT deinterlace you will loose quality when u do this since you shot in HD...but it did work for me i know its a pian because i had 4 hours worth of stuff....


    hope this helps
     
  9. JHacker thread starter macrumors 6502

    JHacker

    Joined:
    Aug 27, 2006
    Location:
    East Coast
    #9
    Ok I tried to take a screenshot of what's going on. The image is alternating between the bad and the good, but in iMovie, it looks like pure goodness. @ Goku - is this what yours looked like before you re-captured in Final Cut?

    Bad:
    [​IMG]

    Good:
    [​IMG]
     
  10. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #10
    Ah! Well then! That is indeed an issue with interlacing. It should look fine if you were to look at it on a TV screen, but this should be fixable for computer use.

    What settings are you using? It looks there like you've exported using some kind of anamorphic NTSC preset, which would probably try to preserve interlacing. At the size you've posted, the fields should have blended together naturally. So I'm thinking even if you were to deinterlace your video before exporting it, you would end up with those lines because it would try to re-interlace at the lower resolution. You could deinterlace the video after export (as I've done with your top screenshot here), but you will end up losing quality if you do it that way.

    When you're setting up your export, make sure to disable anything that mentions "interlaced" or using fields.
     
  11. JHacker thread starter macrumors 6502

    JHacker

    Joined:
    Aug 27, 2006
    Location:
    East Coast
    #11
    I think this time I did use a 16:9 NTSC because I wanted to preserve the widescreen size. I'm really clueless as to how I should be exporting. All I want is a file about this size, that looks good, crisp, clear, HD, but isn't an overly huge file - I'm only exporting videos between 1 and 5 minutes.

    I want it to look like Apple's HD videos! I checked "Deinterlace" in iMovie - but you said the NTSC would counter that? I've definitely tried a variety of settings in the past (that weren't NTSC), but to no avail.

    Is it possible Final Cut Express would do what iMovie isn't?

    Do you think you can look in iMovie and tell me exactly how to set my export so I can try that? I appreciate the help!
     
  12. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #12
    I went in to iMovie and captured some stuff from my 1080i60 HD camcorder. When I was ready to export, I chose "expert settings" and clicked Share.

    In the dialog that came up, I chose to export Movie to Quicktime Movie and clicked the Options... button.

    For the video settings, I chose the H.264 compressor (what Apple usually uses), 1200kbits/sec.

    For the size, I chose the NTSC 16:9 preset.

    I then exported the video, and it came out quite nicely, without the interlaced lines. Here is a screenshot. In this frame, the actress (this was an outtake from a short video I was making) is in motion, so if this was at the full HD resolution she would have a bunch of lines through her, but using the settings I specified above, they're naturally blended out.

    I hope this helps!
     
  13. gokuu macrumors member

    Joined:
    May 12, 2007
    #13
    YES thats exactly how it looked....at first i thought it was the way i taped. and i was freaking in shock and scared since this was a big thing....just recapture a lil clip maybe 5 minutes and check all you settings too. but i think you should be good after that.....i dont know exactly what caused this but it happened to me too.....


    when you de-interlace you will see that the quality shoots down almost looks like heat wave, meaning when you look far into the horizon and things look a bit wavy because of the heat....


    I really hope this works for you. it did for me. crazy but it did.
     
  14. gokuu macrumors member

    Joined:
    May 12, 2007
    #14
    i truelly like personaly final cut express way better than Imovie...faster and easy to use. if you are going to export in final cut express...you have way more options.....i mean way more
     
  15. JHacker thread starter macrumors 6502

    JHacker

    Joined:
    Aug 27, 2006
    Location:
    East Coast
    #15
    Ok I tried again NTSC 16:9 1200kbits/sec H.264, did NOT check de-interlace. I still have the lines. Also, up top, it says my camera is HD-1080i-30. It's an HV10. Could I have imported incorrectly? I think I also checked 24 frames/second?

    Ideas?
     
  16. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #16
    I've made a movie just to make sure you're doing those things. :)

    24 frames/sec could possibly be causing the problem (pulldown... or pullup, I don't remember). Don't export to 24p just to eliminate that as a problem.

    Do you have Quicktime Pro? If so, try exporting your video at full resolution (using the HDV 1080i60 compressor and frame size), and then open it in Quicktime Pro and using Quicktime to export that to your smaller size. You will see lines in the large 1080i version, but exporting it to a smaller size from there should take care of the problem.

    Even if you don't have Quicktime Pro, you could try exporting it at full 1080i, open it in quicktime, and scale the player down to about the size you want it, and play it back just to see that the lines do go away.

    Otherwise I don't really know what else to do? Re-importing would not take care of your problem, so don't worry about having to redo anything. There's just something screwy going on with the exporting.

    Anybody else have ideas?
     
  17. cjstitchman macrumors newbie

    Joined:
    Jun 23, 2007
    #17
    Same problem with me too

    I have have this problem all the time with my HD footage. I can normally fix it quite easily.

    First of all make sure you have Quicktime Pro installed. You can either pay for it (or type Pablo/nop in google and type the results in the registration of 'Quicktime System Preferences.')

    Then open up the movie that has the image quality issues. Once opened go to the 'window' tab then 'show movie properties'

    Once there click on the 'video track' tab, then underneath, click 'visual settings'

    From here you have the option in the bottom right to click 'deinterlace' This shoud make the image quality perfect. Also the 'high quality' button above 'deinterlace' often helps.

    I hope that kinda helps you out.


    [​IMG]
     
  18. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #18
    It should be noted that the solution posted by cjstichman will only work for you during playback, if you send the video to anyone else they will still see the interlacing. This is more of a hack than a solution.
     
  19. CrEsTo macrumors 6502

    CrEsTo

    Joined:
    Jun 23, 2006
    Location:
    Australia
    #19
    What if I use cjstichman's solution, save the file and then burn it.

    Will I still have the same problem?

    I thought that really solved it.
     
  20. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #20
    No, because you're just changing how you want Quicktime to interpret the file, you're not actually changing the file itself. So the lines remain.
     
  21. bmb012 macrumors 6502

    Joined:
    Jul 25, 2006
    #21
    There's a little checkbox under the 'Size' tab in Quicktime Pro export that says 'deinterlace source video.'

    That what you're looking for?
     
  22. fiercetiger224 macrumors 6502a

    Joined:
    Jan 27, 2004
    #22
    Okay guys, I've worked with video a loong time. I think the problem here is HDV codec. And here's why. I'll try to make it easy to understand. :rolleyes:

    When you import footage from a camera directly to the HDV codec, basically it records exactly what the information is from the camera, which means it'll stay exactly that way. So if you imported footage that was interlaced, then it'll be imported interlaced; if you try to play it through Quicktime, it'll show the interlaced lines regardless if you check off deinterlace or not. This is because the codec is decoding compressed information, and doesn't read the information as scanlines. All it does is it decodes the information, and Quicktime displays exactly what the information is, and doesn't natively do post-processing deinterlacing for compressed codecs.

    So here's a solution. You need to export that HDV file to a codec that is uncompressed and supports scanlines. Of course this'll yield a very big file. But once that's done, you can re-export that big file and compress it back down to a smaller file size with proper deinterlacing. Here's a list of codecs that support scanlines:

    -DVCPRO codecs (I'd probably only try DV/DVCPRO - NTSC)
    -Apple ProRes codec (a new codec only on Final Cut Studio 2, although I'm not sure if the latest Quicktime Pro already has the codec compiled in it)

    Assuming you have Quicktime Pro to deinterlace, I'll provide some instructions.

    Step 1: Open up your HDV file. Go to File > Export. Once the "Save as" window pops up, "Export" should automatically select "Movie to Quicktime Movie". If not, then select this option, and then click on "Options" right next to it. Select "Settings", and select a codec that supports scanlines (I'd go with "DV/DVCPRO - NTSC"). You'll know if it supports scanlines by when you select the codec, and there will be an option to select the "Scan Mode", in which case you can choose interlace or progressive. So, for your interlaced footage, you'd select interlace. Then, you'd go under "Size", and specify the correct resolution. Export with those settings, and after that completes, you can re-export that big file to a compressed codec.

    Step 2: When compressing it, open the big file that you just exported, go back to File > Export, click on "Options" (make sure "Movie to Quicktime Movie" is selected). Select a compressed codec under "Settings", such as H.264, and go to "Size" and make sure you check off "Deinterlace Source Video". Export that, and boom, you'll have a playable, compressed, deinterlaced HD source file at the fraction of a file size.

    Of course, you'll probably have a hard time understanding this, but if you follow the steps, you'll get a properly deinterlaced video for viewing on a computer. :D I'm not expecting anyone to understand all this gibberish, since it's hard to explain all this junk. :p
     
  23. Peel macrumors 6502a

    Peel

    Joined:
    Aug 30, 2004
    Location:
    Seattle
    #23
    Actually you'd have to use DVCPRO-HD. DVCPRO NTSC is a standard resolution codec, and only supports 720x480. DVCPRO is a better choice, but there will still be some resolution loss depending on the source material. If the camera shot in true 1920x1080, or even 1440x1080 you will lose some resolution as the DVCPROHD codec resamples the image to 1280x1080 for 60i and 1440x1080 for 50i.
    Quicktime Pro does support ProRes422, but only after you've installed FCS2 or FCP6. It's not a consumer level codec, and isn't included with the Quicktime download.
    Actually both of the formats you mention are compressed formats. They are both intraframe compression types (i-frame), so each frame is compressed, but there is no GOP structure that introduces interframe compression (b-frame and p-frame), so each frame is descrete, and not dependent of other frames. Both HDV and H.264 use this GOP interframe compression.
     
  24. JHacker thread starter macrumors 6502

    JHacker

    Joined:
    Aug 27, 2006
    Location:
    East Coast
    #24
    I used your video and exported exactly this way and it seems to be better! I have to do some other tests. Thanks for the video that was awesome - how do you do that by the way?

    As for the solutions further down - if the solution above worked - is this necessary? Will the file that looks good on my computer not look good on someone else's?

    Also how long should exporting take? Exporting a 2:30 video took like 15 minutes at the above size.
     
  25. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #25
    I'm glad the video helped! :) I used Snapz Pro X 2 to record it. I usually don't like to pay for screenshot-type software, but this one is really worth it.

    H.264 is a very advanced, efficient compressor, and takes a lot of computing power. So it gives you great results, but takes a long time to crunch your video. 15 minutes for a 2.5 minute video sounds pretty typical for it. When you're configuring your compressor settings (where you select H.264 and set the bitrate), there's a part labeled "Encoding:" which gives you two options: "Better Quality (Multi-pass)" or "Faster Encode (Single-pass)." The "Better Quality" option will take twice as long as "Faster Encode," but of course, this affects quality. Just thought I'd mention that stuff. :)

    If compression time is a big issue, you could also try the Sorensen Video 3 compressor instead of H.264. That's what I mostly used before H.264 came out. It's faster, but you'll need to increase the bitrate (so larger file sizes) to get the same quality as H.264.
     

Share This Page