Deactivate Screen Sharing with Apple Support

olfab

macrumors newbie
Original poster
Aug 15, 2017
28
2
Dear all,

Apple Support initiated screen sharing with my MacBook running 10.14.4 event though no checkbox in Preference -> Sharing is checked. Didn't find anything so far.

How is this possible?
How to stop this?

Best regards,
Fabian
 

olfab

macrumors newbie
Original poster
Aug 15, 2017
28
2
No. We were on the phone and he asked if he may have a look on my screen. Then a confirmation dialog popped up on my screeen. I would feel much more comfortable if this service would be deactivated at all.
 

leventozler

macrumors 6502
Feb 18, 2009
307
106
Open 'Screen Sharing' app (via spotlight) go to Preferences > Blocked Users > uncheck 'Allow screen sharing requests from'
 

olfab

macrumors newbie
Original poster
Aug 15, 2017
28
2
Thank you! There are some interesting apps in the folder where "Screen Sharing" resides in.
 

olfab

macrumors newbie
Original poster
Aug 15, 2017
28
2
I understand your point. But I am more comfortable if services I usually do not need do not run since it is more difficult to exploit a not running service. Try to harden the MacBook at least a little.