Dead ATV

Discussion in 'Apple TV and Home Theater' started by spice weasel, Jul 7, 2009.

  1. spice weasel macrumors 65816

    Jul 25, 2003
    Last night, after upgrading to 2.4 and having it reboot just fine, my ATV suddenly started flashing the amber light while I was watching regular TV. I went to check it out and it won't turn on no matter what I do. I tried several hard reboots to no avail, and tried the "menu" plus "-" thing on the remote. Nada.

    I figured my drive had crashed. So this evening I prepped a spare drive I had, pulled the old drive, and swapped them. It still won't boot. Just for kicks, I put the old drive in the USB enclosure and connected it to my MBP. The disk appears perfectly fine, with the normal partitions and volumes.

    Anyone have any ideas as to what could have caused my ATV to die? At this point I'm hesitant to buy another one, and would rather wait until (if?) Apple comes out with a new version. Or maybe save up and buy a mini instead. Until then, I can always connect my MBP to my television.
  2. munkees macrumors 65816


    Sep 3, 2005
    Pacific Northwest
    here are a number of things todo

    also try pinging the the network interface of the device to see it boot and is just not on the network.

    here is a link to using the remote

    a power reset is unplugged power for more than 10 seconds.
  3. musicman0725 macrumors member

    Oct 25, 2007
    Wow, I'm having the same exact problem on my 160GB Apple TV. I updated to 2.4 and the update seemed fine. I also updated my 40GB Apple TV to 2.4. The next morning the 160GB Apple TV had a flashing Amber light. I figured the drive had failed and unfortunately my Apple TV is out of warranty. Interestingly enough, my working Apple TV is 2.5 yrs old and my broken one is 1.5 yrs old. I decided to purchase a WD 250GB PATA drive since they are $80 right now. I properly configured the new drive according to various threads and when I placed the new drive in, it still didn't work so I returned it.

    Today, I opened up both Apple TVs (the working 40GB and the broken 160GB). Basically, after swapping the drives, the 160GB drive is working perfrectly in the 40GB enclosure. The 40GB drive will not work in the 160GB Apple TV body.

    Since both HD's work, the update must have screwed the bootloading part of the firmware (you can hear the drive spin up, it just doesn't access it or boot). So far I've been unable to boot with USB on the broken device. Let me know if you make any progress and if anyone else has experienced this issue, please post!!!!!
  4. geoffreak macrumors 68020


    Feb 8, 2008
    My AppleTV has a blinking light whenever I first plug it in. It is unresponsive and doesn't output anything to the TV, but this behavior goes away after less than a minute.
    Have you tried unplugging and plugging back in?
  5. spice weasel thread starter macrumors 65816

    Jul 25, 2003
    Several times, and each time I've left it plugged in for several minutes (up to 15 at one point), all to no avail. I'll keep tinkering around and see if I can get it to work. But if it's dead, it's dead. Oh well.
  6. musicman0725 macrumors member

    Oct 25, 2007
    Same here. It just keeps blinking amber continuously. Obviously, I had to unplug the Apple TVs in order to switch the HD from one machine to the other, but I did do some testing leaving the machines on for an extended period of time while they were opened up. Since our hard drives are in working order, and this issue occured right after a software update, it seems very likely that the EFI (replacement in Intel Macs for BIOS) did not update correctly on the machine during the update, thus the HD is not recognized during bootup. I certainly feel a software update should not fry a machine like this had, but I don't expect much luck convincing apple to replace an Apple TV out of warranty. When I called in to see if there was anything they could do before opening the machine up and troubleshooting myself, they told me I could buy a new Apple TV. No thanks!!! You might have better luck over the phone or in an apple store. I don't really expect them to do much...I just wish I had purchased Apple Care (it's only $35 from J&R )
  7. dynaflash macrumors 68020

    Mar 27, 2003
    hmm, tbh I have just started having some issues intermittently with freezing and even some no hd icons in the last three or four days. Figured maybe my eSata drive was on the blink. But now that you mention it I did just recently update .....
  8. dynaflash macrumors 68020

    Mar 27, 2003
    update: was a wonky mybook hd. switched drives and solid as a rock. so apparently the update is fine here.
  9. spice weasel thread starter macrumors 65816

    Jul 25, 2003
    Yeah, I never really suspected the update as causing my ATV to fail. Just coincidence. I really thought it was the drive. But that doesn't seem to be it. I'm not sure what happened. In cases like these, I just blame the gadget gremlins.

Share This Page