Dead battery, or something else?

Discussion in 'MacBook Pro' started by charmston, Jul 28, 2007.

  1. charmston macrumors newbie

    Joined:
    Jul 28, 2007
    #1
    Hey all,

    Today as I was busy using my 13.1" Macbook, my machine suddenly went to sleep. I was using the power adapter at the time, so I was perplexed, since it seemed like a dead battery issue. It turns out that I bumped the magsafe adapter, and the second that it unplugged it went to sleep. After some experimenting, this is what I know:

    • With the battery and power source plugged in, it works fine. The battery icon in the menu bar claims that the battery is full. The magsafe adapter is lit up green.
    • With the batter out and power source plugged in, the computer functions fine. The menu bar icon has a black "x" in it.
    • So far this is expected behavior. But when I unplug the power adapter, the laptop shuts off and will not start back up until it is plugged in again

    I've already reset the PMU and done some investigating with the battery connections. All appears to be in order. The charge indicator on the battery itself acts quirky, however. When you press the button, it quickly (moreso than normal) lights up completely, then the lights go dim (at maybe 30% the normal luminosity) for 5 seconds or so. All signs point to a hardware failure with the battery, but the nearest Apple store is quite a ways away from me and I wanted to make sure that there's no chance that it's another issue before I make the journey there. Any thoughts?

    Many thanks!
     
  2. Teh Don Ditty macrumors G4

    Teh Don Ditty

    Joined:
    Jan 15, 2007
    Location:
    Maryland
    #2
    Is your battery affected by the battery recall? Head over to apple's website to find out.

    EDIT: Here's a link to Apple Support
     
  3. charmston thread starter macrumors newbie

    Joined:
    Jul 28, 2007
    #3
    Huh, strange, I don't recall hearing about this battery recall. It does appear that that was the issue.

    Thanks, Don Ditty!
     
  4. Teh Don Ditty macrumors G4

    Teh Don Ditty

    Joined:
    Jan 15, 2007
    Location:
    Maryland
    #4
    You're welcome! I had the same problem with MB, I took it to the Apple Store and got a new one on the spot.
     

Share This Page