Dead computer thoughts on problem

Discussion in 'MacBook Pro' started by Jigsawjammer, Oct 29, 2013.

  1. Jigsawjammer macrumors regular

    Joined:
    Apr 29, 2009
    Location:
    NYC
    #1
    Hi all- haven't posted in awhile but can use some help. I also have searched here and the web but can't draw a conclusion. I will keep it short and concise as possible.

    So here is the backstory-
    Mid 2009 13" MBP. Worked fine all this time. No new programs loaded recently. Working and surfing the web and hard drive is "missing". Can't save my work or do anything else. Shutdown and restart to the flashing folder icon. Reset Pram, tried to boot safe mode, took hard drive out to see if cable was loose from drive to board, tried to use snow leopard disk to run first aid but hard drive is not showing.

    So at this point I suspect the cable went bad since this is a common problem or HDD is dying.

    Today, after a day of rest, comp boots and seems fine. Quickly back up as many of my newer files then run disk utility. Says disk is fine. Repair permissions and seems no issue. Then comp starts acting funny. Can't search n the Internet and safari reboots constantly, fan seems to be getting louder and hotter, blue screen appears with only safari and activity monitor now in dock- comp doesn't work.

    Shut down, get the "no" sign (circle with a slash)- shut down and try to boot into safe mode with no luck-no sign stays on screen with spinning gear nonstop- boot into single user mode (think that's it) - boots a black screen with info about boot- comp stalls and says "still waiting for root device" over and over again without getting past that screen.

    Trying to boot again but just get the no sign, and extremely hot comp, and a spinning gear.

    Oh- before it's second shutdown- I suspected something was wrong since the comp was getting warm for no reason so I opened activity monitor. Most CPU was used on something called "syslogd". It hit 103% at one point!

    So- based off this- what do you guys think? I was about to order a new HDD cable to see if that was the fault but I'm starting to wonder if this is truly the problem. I was also think getting an external for the HDD to see if it's truly the problem. I looked online and similar problems seem to say that the HDD can be the problem along with a faultylogic board.

    Thanks everyone.
     
  2. kfmfe04 macrumors member

    Joined:
    Jun 19, 2010
    #2
    Start Console.app to see what that syslog is outputting.

    FWIW, I also have a mid 2009 13" mbp. I suspect you are having some HDD issues, but the output on the Console should give you a better idea of what is happening.

    If you choose to replace your HDD, I highly recommend going for a SSD (I ended up with a Intel 335 240GB after dropping my mbp and killing the HDD about a year ago) - it'll extend the "useful life" of your machine by at least another year.
     
  3. Jigsawjammer thread starter macrumors regular

    Joined:
    Apr 29, 2009
    Location:
    NYC
    #3
    How do I do this??? Thanks
     
  4. KUguardgrl13 macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #4
    I'm not too sure about the CPU issue, but I've had the missing hard drive happen once as well as a host of other issues that Apple always says is the SATA cable. Lately they haven't even bother to replace an obviously burned out cable; they just say it needs to be "reseated".

    I just got a new rMBP, so fixing my 2009 hasn't been a priority. Although it'd be nice to have a second laptop with a SuperDrive.

    I hope you can get this figured out! I haven't run into too many people suffering from the same issues as me.
     
  5. Beezy253 macrumors 6502

    Joined:
    Sep 19, 2013
    Location:
    Tacoma, WA
    #5
    IMO, it sounds like the hard drive failed…

    This happened to my 2009 MBP about 6 months ago. Installed a Samsung 840 Pro, and it's like a whole new system. (minus the terrible battery life)
     
  6. triplelucky macrumors regular

    Joined:
    Sep 30, 2012
    Location:
    Tucson, Arizona, USA
    #6
    On that cable issue….

    I had a mid 2009 15 that would see the drive, then not, then see, then not…

    Changed the cable and same thing.

    It ended up being the connector on the logic board that had oxidized enough to cause the problem.

    After cleaning the pins on the inside of the logic board connector the problem was resolved.
     

Share This Page