Dead Drive?

Discussion in 'Mac Accessories' started by Forgott3n, Jan 11, 2009.

  1. Forgott3n macrumors newbie

    Joined:
    May 12, 2008
    #1
    Hello,

    I am having a huge problem and its spooking me. I have a Comstar 500GB USB 2.0 external harddrive (CO-EXOT-500WEB) from Futureshop and its stopped responding.

    The drive is formatted as a Time Machine backup (also has a few folders with photos) and has a light that goes red with power and blue with disk activity.

    After having the drive unplugged and stored somewhere for 2 weeks I tried plugging it in to my Macbook Pro 17" (10.5.6 Leopard) but no blue light showed, no sound of the driving spinning up or clicking, and nothing showed on screen.

    I think the drive died. I think it was also listed at /dev/disk1/ but I had no idea of being sure, but I ran a smartctl -a just in case:

    Code:
    justin-bulls-macbook-pro:~ Justin$ sudo smartctl -a /dev/disk1s1
    smartctl version 5.38 [i386-apple-darwin9.6.0] Copyright (C) 2002-8 Bruce Allen
    Home page is http://smartmontools.sourceforge.net/
    
    Smartctl open device: /dev/disk1s1 failed: No such file or directory
    justin-bulls-macbook-pro:~ Justin$
    
    As you can tell, nothing really happened. Right now the drive is plugged in and turned on. Its making no noise and the red light (power indicator) is on.

    What can I do to test / recover / fix my drive?

    Thank you for the help!
     
  2. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #2
    Sorry, I don't know that drive but is it bus-powered or has a stand alone PSU?
     
  3. Forgott3n thread starter macrumors newbie

    Joined:
    May 12, 2008
    #3
    Stand alone PSU.
     

Share This Page