Dead G4 Laptop

Discussion in 'Macintosh Computers' started by kingkool68, Mar 12, 2005.

  1. kingkool68 macrumors newbie

    Mar 12, 2005
    My friend has a 15" G4 Laptop and it's a little more than a year old. Today he tried plugging it into the charger and the charging light is pulsing. I can't get his computer to start unless I hold the power button down for a good 15 seconds or so. Then everything boots up and it gets to the screen where it asks for the password. Before I can enter the password, the screen goes black and won't respond. If I try pressing the power button the screen comes back up asking if I want to shut down, sleep, etc. After pressing Cancel the screen goes black again. If I put my ear to the keyboard I can hear a sort of alarm sound, very faint. The sound is in rhytm of the pulsing light. so my question is?

    1) Is it a battery problem or hard drive problem?

    2) Anyone have any tips on how to resolve this?

    3) Called the support from the store where it was bought and they hadn't a clue.
  2. Stampyhead macrumors 68020


    Sep 3, 2004
    London, UK
    Wow, that sounds bad. I doubt it is a battery problem, as it happenes while plugged into the charger. Does your friend have AppleCare? If so call Apple and see what they suggest. If no Apple Care, I would contact a local Apple repair place and see what it would cost to fix it.
    Good luck!
  3. simie macrumors 6502a


    Aug 26, 2004
    Options to try

    1. I would first check your battery could be dead try it in another laptop if possible.

    2. Then try changing the ram - could be faulty.

    3. Try reseting the Power Management if the ram and the battery is ok.
    Press the Command-Option-Control-Power On keys simultaneously and let go. Pressing the keys will not appear to do anything. You may have to read just the screen settings. then charge the battery.

    If any of the above worked then reset the pram.

    Your friend as the firmware password enabled - so you can't reset the pram until you get into the Openfirmware.

    Hold down Option-O-F key gets you in Open firmware
    Type in reset-nvram
    You are asked for your password.
    Type in Reset-all
  4. Mechcozmo macrumors 603


    Jul 17, 2004
    I'd call up AppleCare... does it make any extra noises when it starts up? Those are often critical in figuring out what broke.
  5. Passante macrumors 6502a


    Apr 16, 2004
    on the sofa
  6. kingkool68 thread starter macrumors newbie

    Mar 12, 2005
    Found the Problem

    In case anyone else runs into this, the culprit is a bad charger. Tried a different charger and the charger light stopped blinking and began charging the battey. Thanks for the help guys!

Share This Page