Dead iPhone 5 after bad car charger

Discussion in 'iPhone' started by felipeiphone, Nov 5, 2015.

  1. felipeiphone, Nov 5, 2015
    Last edited: Nov 5, 2015

    felipeiphone macrumors newbie

    felipeiphone

    Joined:
    Nov 5, 2015
    #1
    Hey guys, I've had iphones since 2009 and never needed to use macrumors! But now my problem is kind of big, let's see if someone can help me!

    - I have an iPhone 5, model A1429, up to date with all iOS updates.
    - I live in Brazil. This model has no warranty coverage in my country nor can be fixed by authorized tech companies.

    I tried to charge the iPhone with my Griffin car charger and the cable had a short circuit just after connecting. After that, the battery started draining around 1% per minute, but phone still on. When I tried to turn off and on again it never came back to life.

    I took it to a tech company near home and they tried changing the battery for a new and charged one and also tried to recharge my battery outside my phone. They also tried to change the display thinking it could have gone down but nothing worked. I asked if it could be the dock connector board and they say if you put a fully charged battery the phone should at least turn on. They said my phone is dead forever.

    I read some articles that say sometimes at my situation an item on the logic board fries and there is no fix.

    That's it! Hope someone has some fix idea!

    *UPDATE*
    Now, after the tech shop recharged my batt I try to turn it on and see that icon of RECHARGE ME. But still after connecting the phone to power it keeps showing the same icon...with the cable drawing, as if it was not connected...

    Thanks,
    Felipe
     
  2. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #2
    Sound like the circuit board got fried and fixing it would be near impossible.

    Sorry for your loss
     
  3. djransom macrumors 68040

    djransom

    Joined:
    May 14, 2008
    Location:
    Chi-Town
    #3
    I remember this happening to a 5S I had about a year ago and Apple ended up having to replace the phone completely.
     
  4. felipeiphone thread starter macrumors newbie

    felipeiphone

    Joined:
    Nov 5, 2015
    #4
    UPDATE
    Now, after the tech shop recharged my batt I try to turn it on and see that icon of RECHARGE ME. But still after connecting the phone to power it keeps showing the same icon...with the cable drawing, as if it was not connected...

    Does this change anything?
     
  5. CNeufeld macrumors 6502a

    Joined:
    Nov 25, 2009
    Location:
    Edmonton, AB
    #5
    I suspect your phone is dead. The "fix" would be to replace the phone with a new one.

    C
     
  6. iPad Retina macrumors 6502a

    iPad Retina

    Joined:
    Jan 6, 2013
    Location:
    Canada

Share This Page