Dead Logic Board?

Discussion in 'MacBook' started by StockDC2, May 16, 2011.

  1. StockDC2 macrumors regular

    Joined:
    May 16, 2011
    #1
    Hi, I have 2 Macbooks (pre-unibody), both of which the same problematic symptoms. When either is turned on, the computer chimes and the screen flicks to a dark black. The fan begins to spin but there are no signs of hard drive activity.

    I've tried swapping out the memory and trying individual slots all to no availability. I know that this is not likely but could a dead PRAM battery cause this to happen? I've been reading about mixed thoughts on this and am hoping for a definite answer. Thanks in advance!
     
  2. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
  3. StockDC2 thread starter macrumors regular

    Joined:
    May 16, 2011
    #3
    Yes, I've done both on both machines. Still no luck :(.

    When doing the PRAM reset, I also made sure to hold the buttons until the 3rd chime was made. Even then, all I ended up with is a black screen.
     
  4. AshMan macrumors regular

    Joined:
    May 1, 2010
    #4
    Anything show on screen at all? Tried external monitor? Checked to see if it is an LCD issue?
     
  5. StockDC2 thread starter macrumors regular

    Joined:
    May 16, 2011
    #5
    Unfortunately, there is nothing on the screen. I've tried swapping the LCDs to no availability. I'm quite certain that both LCDs work.

    I have not tried using an external monitor because I do not have the DVI connector :(. Even if I did, I'm sure that it wouldn't work since nothing is being displayed on the LCDs.
     

Share This Page