Dead powerbook - diagnosis help

Discussion in 'PowerPC Macs' started by gibbon rib, Nov 6, 2010.

  1. gibbon rib macrumors newbie

    Jul 28, 2010
    Hi, just wondering if anyone could give me some diagnostic tips with a very unhappy powerbook. I’ve tried the Apple support pages, but they didn’t do the job so I thought I’d look for some helpful experts – I will be immensely grateful if you could help me figure out what’s wrong.

    It’s a G4 Power book, running OS 10.4. It suddenly froze on me one day, so I held down the power button to reboot and it hasn’t worked since. One thing that I guess could be relevant is that it was pretty much out of disc space – it had flashed up the warning a few times in recent days and I was in progress of doing a clean up when it went.

    What I’ve tried so far:

    Normal power up:
    Result: Chime, apple logo and spinning logo appear. Stays that way for 4 mins, until screen goes darker grey and “You need to restart your computer. Hold down the power button for several seconds or press the Restart button.” message appears.

    Safe boot (with progress status) – power up holding shift-command-v:
    Result: Chime, apple logo appears, nothing else. Stays like this for ~30 mins until I give up and power down.

    Reseting PRAM and NVRAM – power up holding command-option-p-r
    Result: Chime, then restarts and second chime, then does exactly the same as the normal power up.

    Next step recommended by the Apple Support site is to start directly from the OSX installation disc – but my powerbook already has a CD inserted which I am unable to eject.

    Any tips – how can I eject? Could the safe reboot take more than 30 mins (bearing in mind it didn’t give me any progress indication)? Anything else I should try?

  2. Hrududu macrumors 68020


    Jul 25, 2008
    Central US
    Safe boots do take much longer than a regular boot, but 30 min is a bit long. You might try booting into single user mode and running fsck on the drive to see if you can repair it. You are probably going to need an OS reinstall though.
  3. gibbon rib thread starter macrumors newbie

    Jul 28, 2010
    Thanks - managed to eject the disk and attempt an OS install, but it says I'm down to 1.6GB free, but 1.9GB required. Any way to install without deleting users?
  4. Stephen Dowling macrumors regular

    Stephen Dowling

    Jul 29, 2009
    New Mexico
    Hey OP, it might be a failing HDD. Same thing happened to me, it was a bad disk. I had the same exact problem. What are the spec's of your PB?

    Best of luck!
  5. gibbon rib thread starter macrumors newbie

    Jul 28, 2010
    Yup, dead hardrive looks likely, disk utility repair says:

    The volume Hardrive could not be repaired.
    Error: The underlying task reported failure on exit
    1HFS volume checked
    1 volume could not be repaired because of an error
    Repair attempted on 1 volume
    1 volume could not be repaired​

    Anyone know of the chances of recovering data? My backups are not as up to date as they should be but not too bad, but I think there are a few baby photos on there I'd love to get hold of.
  6. Yanal macrumors newbie

    Aug 3, 2009
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A306 Safari/6531.22.7)

    It woulda came out with the question mark icon if it was a dead drive,, try target mode, maybe there's still some life to the drive, it's worth a shot. Start it and hold the T button
  7. eyoungren, Oct 20, 2015
    Last edited: Oct 20, 2015
  8. Mnowell69 macrumors regular


    Jul 4, 2013
    Bedford, UK
    Just thinking, you may get DISK REPAIR failure if the HDD is full. I don't know if a full disk will stop it from booting though.
  9. weckart macrumors 601

    Nov 7, 2004
  10. Altemose macrumors G3


    Mar 26, 2013
    Elkton, Maryland
    Not all dead drives disappear off the face of the earth, er ATA controller.
  11. eyoungren macrumors Core


    Aug 31, 2011
    ten-zero-eleven-zero-zero by zero-two
    Guys this is one of three five plus year old threads that were dragged up by an abusive user last night. The user was reported, his posts removed and this is what we have left.

    We probably should move on. ;)

Share This Page