Dead Powermac G4 MDD help?

Discussion in 'PowerPC Macs' started by vitorio, Feb 8, 2010.

  1. vitorio macrumors newbie

    Feb 8, 2010
    hi everyone, i've been reading the forums for some time (mostly around apple update time), but now the time has come to participate

    Recently i got an old powermac G4 from a friend. He got it from his company, because it was dead. It is a MDD model, with dual 1.25GHz cpu's and a radeon 9000. Ram and HDD were missing, but i have spares for that.

    Now i plugged in the power, and it didnt do anything, nothing at all. So i opened it up, and turns out the PSU is fried (fuse blown, apperently G4 PSU's die a lot). So i spent last night adapting a normal ATX psu to the G4's wiring harness. (leaving the 25v alone, which apparently is only needed for the ADC).

    Now it still doesnt start up, when i push the power button really hard, it lights up sometimes, untill i take my finger off, then it fades away, and thats all it does. I tried the PMU reset in several ways (with battery, without battery etc..), and still, nothing.

    Does anyone have a good idea of how to fix this? I would love to get this machine up and running, since it would be a nice machine to discover OS X on (leopard anyway), but if it is dead, then so be it..
  2. dbculp macrumors member


    Dec 29, 2009
    Mdd Psu

    When I put an ATX PSU into a Digital Audio G4 I ran +12V to the +28V pin and that was enough to allow the machine to boot. Double check your wiring, the MDD layout is kind of odd and very different from anything else.
    The problem might just be the front panel button, apparently they are known to go bad.
  3. vitorio thread starter macrumors newbie

    Feb 8, 2010
    hmm i see, i'll hook the 25v to the 12v rail and try that

    as for wiring layout, i just cut the 24pin connector from the mac PSU and tied the wires into and ATX female plug, grouping them by color (color/voltage is the same in ATX/Mac)

    I assume i can fake a power up by shorting two mobo pins in under the front panel connector? any idea which two pins to short?
  4. AlexMaximus macrumors 6502a


    Aug 15, 2006
    A400M Base
    G4 Power supply to ATX conversion

    Hey there,

    attached are some infos that helped me a lot with my past G4 project.

    G4MDD - ATX conversion:

    and this :

    .. as well as this:

    You should be able to find out what you have missed, once you have read/watched the articles mentioned above.

    Good luck to your G4 project!

  5. vitorio thread starter macrumors newbie

    Feb 8, 2010
    well, i modified my wiring slightly:

    - ran 12v to the 25v rail on the mac connector
    - isolated the 3.3v sense wire from the rest of the 3.3v rail

    sadly to no effect, then i ran my screwdriver across the front panel connector to try and jumpstart it in case the powerbutton was wonky, yet no luck

    all that happens with this thing is that the power button lights up when i push it really hard, nothing else what so ever :(

    anyone else have a brilliant idea on how to fix this thing? or is it just a dead mobo?
  6. OrangeSVTguy macrumors 601


    Sep 16, 2007
    Northeastern Ohio
    Make sure the processor daughter card is fully seated. If it's dead or not connected, the G4 won't even turn on.
  7. dbculp macrumors member


    Dec 29, 2009
    MDD Startup

    This may sound a little odd but try pushing the power button until it momentarily lights up, unplug the computer for 10 seconds, plug it in and immediately push the power button again.
    You can also try bypassing the front power switch by putting a jumper from the green startup wires to the grounds next to them.
  8. vitorio thread starter macrumors newbie

    Feb 8, 2010
    well, i reseated the cpu card, and redid the thermal paste while i had the heatsink off, no effect

    i tried the 10 second trick, didnt work. I tried jump starting the psu, which works, if i try jumpstarting it with the mac attached, nothing happens (psu doesnt power up), although the fans gives a tiny little twitch, as though the psu wants to spool up for a fraction of a second, but the system cuts out the startup...

    so the thing still is dead as a doorpost

    any more suggestions, or should i just throw the thing in the trash?
  9. arogge macrumors 65816


    Feb 15, 2002
    I have this same problem with the same computer version. I had the computer powered off because of power outages, and when I pushed the power button, nothing happened. When I push it hard and hold it down, the light turns on but fades off as soon as I let go. What I did notice is that the fans have been making unusual noises over the past few weeks, sometimes there would be no video signal after Wake from Sleep, and my new DVD drive was suddenly not spinning up DVDs or was failing to finish writing them. Maybe Apple killed our computers as part of some sort of forced upgrade plan.

    Maybe this could mean that new product releases are coming this week! It's a sign that's it's time to upgrade. :D

Share This Page