Dead SATA Cable or Temperamental SSD?

Discussion in 'MacBook Pro' started by ethan-1878, Dec 13, 2014.

  1. ethan-1878 macrumors member

    Joined:
    Jun 8, 2014
    #1
    About a year ago (early January) I opened up my mid-2012 MacBook Pro, Optibayed it and fitted a 500GB SSD in the main bay. I had Mac running off a home-made fusion drive which consisted of 250GB SSD space and the 500GB, Apple supplied Toshiba, HDD and a BOOTCAMP partition with the other 250GB of SSD.

    Last Saturday (06/12/2014) I tried to power on my MBP but got the grey screen with the 'no entry' sign. I rebooted my MBP into the Internet Recovery option (no recovery partition was recognised) and fired up Disk Utility. DU told me that there was an error with my Fusion Drive but it could be fixed by clicking the 'Fix' button at the cost of erasing both drives. I clicked 'Fix' as I had everything backed up already and a working MBP is more important to me.

    After clicking 'Fix' and installing a copy of Mountain Lion, booted my MBP. First boot tok about 3 minutes but I thought nothing of it as first boot always takes somewhat longer. Set up the now fixed MBP to find that the sluggish boot time was caused by my MBP still not recognising my SSD.

    I've tried plugging the SSD in using a SATA to USB adapter and it showed up and worked fine - put it back into the MBP and no longer recognised.

    I did make an appointment at the Genius Bar but unfortunately couldn't make the appointment and the next one isn't until Friday 19th - I just can't wait that long.

    Is there anything I can do to make sure that it definitely is the SATA cable? If so, I'm just going to buy one off eBay and fit it myself.

    Thanks,

    Ethan.
     
  2. jsagurton macrumors member

    Joined:
    Aug 6, 2014
    Location:
    Pennsylvania
    #2
    You could try using another drive on the same cable, but it seems extremely likely it's the SATA cable, especially if the SSD works in a USB enclosure. I'd just bite the bullet and buy it.
     

Share This Page