Dead Space on Macbook Pro Late 2008. Problems!

Discussion in 'Mac and PC Games' started by mcorleone, Feb 4, 2009.

  1. mcorleone macrumors regular

    mcorleone

    Joined:
    Oct 9, 2008
    Location:
    Florida
    #1
    I have a 2.8ghz late model aluminum MacBook Pro and Windows Vista through Bootcamp.

    The installation went fine but upon the menu screen, first the sound cuts out then it crashes and Windows simply says "There was a problem running this program etc...". I had played Tomb Raider:Underworld on it before and no problems there. I don't see that hardware should be an issue. I have the latest version of Direct X so anyone out there have a similar problem and/or solution to get it up & running?
     
  2. JackAxe macrumors 68000

    JackAxe

    Joined:
    Jul 6, 2004
    Location:
    In a cup of orange juice.
    #2
    I have it on my PC, but it's something I put together. I have a 17" aluminum MacBookPro, but it's not setup to run Windows.

    I recall one of the reviewers playing this game on a 2.4Ghz aluminum, so it should work on yours.

    Which version of Windows are you running? I would make sure that's up to date with the latest service pack. Also make sure your nVidia drivers are current. I played it under XP64 without any problems.

    When you get it running, you'll need to turn off vsync, or else the mouse cursor lags. They were lazy on how they implemented it.

    I'll check around, but I hope you get it running soon. I really enjoyed this game. It's every bit as good as Resident Evil 4, if not better in areas.
     
  3. mcorleone thread starter macrumors regular

    mcorleone

    Joined:
    Oct 9, 2008
    Location:
    Florida
    #3
    OK, I've tried the latest NVidia driver etc. and there's no patches available as of yet! :mad: Is there some updated graphic driver from Apple to get it working? I got the game at Circuit City on sale due to the store close-outs and there's no refunds! Help!!!
     
  4. JackAxe macrumors 68000

    JackAxe

    Joined:
    Jul 6, 2004
    Location:
    In a cup of orange juice.
    #4
  5. aluminumapple macrumors regular

    Joined:
    Jan 7, 2009
    #5
  6. Winni macrumors 68030

    Winni

    Joined:
    Oct 15, 2008
    Location:
    Germany.
    #6
    Dead Space runs perfectly on my Xbox 360, like all the other games that I have for her. Since I gave up on PCs and Macs to play games, gaming has become fun again.

    Okay, I have to admit that switching to the Mac in 2005 was my #1 reason why I bought an Xbox 360. Even Mac Pros suck for gaming, end of discussion.

    My recommendation: Stop worrying and buy yourself an Xbox.
     
  7. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #7
    I already have an Xbox 360, and I've been playing games on my Mac Pro a lot more lately. The consoles in my house get almost no love. ;)
     
  8. JackAxe macrumors 68000

    JackAxe

    Joined:
    Jul 6, 2004
    Location:
    In a cup of orange juice.
    #8
    Dead Space runs perfectly on my PC, as do all of my games. So it's not just your 360 that is special. :]

    You know, quite a bit has changed in the past 4 years. PCs have improved by leaps and bounds over the tech from that time, your 360 is still the same -- given it's even the original. ;)

    Stop worrying... That equates to shelving a game he just bought, buying a new console, then buying a the game again at a higher price. That's not very helpful.
     
  9. Rayban macrumors member

    Rayban

    Joined:
    Sep 5, 2008
    #9
    Do you have 32 or 64 bit Windows? I remember having a problem running Bioshock in 64-bit but it ran fine in 32. But that was on a PC rig I built so I don't know if would be any different on a Macbook.
     
  10. JackAxe macrumors 68000

    JackAxe

    Joined:
    Jul 6, 2004
    Location:
    In a cup of orange juice.
    #10
    I played Dead Space under XP64 without any problems, so I'm not sure that's it.

    I can't speak for Vista, but from what I understand, the newer versions are pretty solid.

    Hey mcorleone,

    Can you post the entire error? It would help, as if other people have had the same problems, you can usually find them under google.

    Also try this;
    Right click on the deadspace.exe, then choose "Run as administrator."

    And try this;
    Disconnect all of your USB devices expect the mouse and keyboard and see if it will launch. I read that game controllers or other similar HID devices are causing it to crash at launch., One guy hat a Gougar joystick plugged in and that was enough to prevent it from going -- hurray for QA, or should I say the lack of it.

    Also, did you install this on the C drive? I read that installing on other drives was causing crashes at launch. If not, then do a complete uninstall, deleting all saves and settings, then install it to your C drive.
     
  11. mcorleone thread starter macrumors regular

    mcorleone

    Joined:
    Oct 9, 2008
    Location:
    Florida
    #11
    I'm running under Windows Vista Basic 32 bit version. I just let the game install under the default under the C drive. I had uninstalled and reinstalled once before with no results. I did try running it under the administrator and no controller plugged in. I did get farther than before. However the sound still cut out on the menu screen. I was able to see part of the intro. The graphics did look as crisp & smooth but there was no sound but eventually I got the same error that said "A problem caused the program to stop working correctly. Windows will close the program & notify you if a solution is available." I would have to press Ctrl/Alt & Escape to get the cursor to come back to close it out.

    When you say to install it under the C drive do you mean not to include the Program Files/Electronic Arts sub files and just install it under "C:/Dead Space"?
     
  12. JackAxe macrumors 68000

    JackAxe

    Joined:
    Jul 6, 2004
    Location:
    In a cup of orange juice.
    #12
    Yep on the location and the default is always better.

    So I'm assuming you don't have any other USB devices plugged in? Try unplugging everything, then restarting with just the mouse.

    I missed your comment about the graphic driver from Apple earlier. You'll actually want to goto nVidia's site and use their drivers;
    http://www.nvidia.com/Download/index.aspx?lang=en-us

    Also do you have any 3rd party firewalls running? I just use XP's option that MS included with later updates.

    This guy found an odd way to get it going, which would be worth trying;
    "I've got the game to work but in a weird way. I had to go into Task Manager. Click on explorer.exe and the process tree then still in task manager open dead space.exe and it works. you can Alt+Tab back to dekstop and open explorer.exe and go back into the game and it still works. Should work for people having problems.

    http://forums.techguy.org/games/779205-dead-space-exe-has-stopped.html

    My PC board is an Intel brand with Dolby Digital on the board, so I think once we get past why it's not working on your system, your sound should work, as the MacBook Pros and desktops use similar setups.

    And I think it's safe to say that you're not running any kind of GPU overclocker, like RiverTuner? If so, definitely turn it off.

    One other thought, but it would cause a problem everywhere, is if you have a bad memory chip. This caused my friend's MacBookPro to crash in PC games at first, then later it would crash in OS X. It was just one of the chips. After replacing it the system ran fine.
     

Share This Page