Dead USB port? (Canon Pixma MP520 related?)

Discussion in 'iMac' started by Hello.there, Dec 21, 2007.

  1. Hello.there macrumors 6502a

    Hello.there

    Joined:
    Oct 12, 2007
    Location:
    Couch
    #1
    Evening all,

    My new Canon Pixma MP520 printer arrived today but I was having trouble from the start with getting it to work with Leopard. I got an update from the Canon site and it printed (once) perfectly, but from then on I got no response from it at all. (After every attempt to print, a message came up telling me the printer wasn't connected - it was).

    Later on I tried the printer in a different USB port at the back of the iMac and...it worked! I tested the 'dead' port with a few other devices (ipod, keyboard, etc) and there was no sign of life - I never had a problem with that port before.

    Has anyone had a similar experience? Has the printer, somehow, murdered that port, so to speak? Help? What do I do? Even with a Hub I'm running out of USB ports!
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Does the "dead" USB port work if it's the only one with a connected device? That'd be a good way to see if it's a power supply issue. In the meantime, maybe try resetting your SMC. :)
     

Share This Page