Deadline for buying jailbreak-able iphone: Sep 8?

Discussion in 'Jailbreaks and iOS Hacks' started by self, Aug 29, 2009.

  1. self macrumors regular

    Joined:
    Jul 11, 2008
    #1
    For everyone that definitely wants to jailbreak their iphone, shouldn't they run out and buy one now before 3.1 is released on Sep 8? Or can you always downgrade 3.1 to 3.0.1 and do the jailbreak?
     
  2. JonHimself macrumors 68000

    JonHimself

    Joined:
    Nov 3, 2004
    Location:
    Toronto, Ontario
    #2
    They could also just wait for the jailbreak/unlock for 3.1 after it's released. I can't imagine it would take too long for it to be broken.
     
  3. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #3
    Although you can downgrade, if there has been a baseband update, this won't get downgraded, and as such Ultrasn0w might not/probably won't work in which case you'd be screwed.

    The only way it might work is if someone wrote another baseband downgrade program for Cydia and then you might stand a chance, as even that program has pre-reqs
     
  4. Almy macrumors 6502

    Joined:
    Sep 27, 2008
    #4
    I would imagine no iPhones for sale will come with 3.1 for a bit. Probably plenty of time. Not like they update the firmware of all that stock out there.
     
  5. wingsabr macrumors 6502

    wingsabr

    Joined:
    Dec 13, 2008
    #5
    Jailbreak has been available for each version, it just takes a little bit of time. Apple tries and the DevTeam fries!
     
  6. self thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #6
    Hey guys... So according to all the posts about 3.1... It sounds like it may not be possible to jailbreak unless you saved the iBEC and iBSS files from when the phone was at 3.0. And that it's even more unlikely you'll be able to unlock because of the new baseband.

    Now I'm regretting not buying an iphone before Sep 8 (actually 4 of them)! What do you think the chances are of getting 4 phones with 3.0 or 3.0.1 if I walk into an Apple store tomorrow? Is there any way for them to check the version on the box before I decide whether to buy/upgrade?
     
  7. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #7
    Why do you want 4 iPhones? Anyways, like someone said earlier, they don't upgrade the firmware of their current stock, so there's a chance that if you buy one tomorrow, it'll be either 3.0 or 3.0.1. Also, since 3.1 is out, you can't capture the iBEC and iBSS files anymore (at the moment), but you can still JB/Unlock using Redsn0w and Ultrasn0w if you get an iPhone with 3.0 and 3.0.1. DevTeam is awesome and everyone just needs to be patient and wait for them to release a new version of pwnage tool or whatever it will take to JB/Unlock 3.1 :)

    EDIT: Hmm, maybe not :(
    iPhone preloaded with 3.1:
    http://forums.macrumors.com/showthread.php?t=785430
     
  8. self thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #8
    4 family members. Yeah I know (now!) about it being too late to capture iBEC and iBSS. Didn't realize there was a deadline for that as well or I would have done that with my own phone :( I'm hoping the DevTeam will succeed but from their blog it sounds like they're doubtful about the unlock.

    Guess I'll try asking for one with a serial number older than week 37! Thanks.
     
  9. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #9
    Yeah, that's what I'm going to be doing too...I guess. Just curious, what are you going to say if they ask you why you want one older than week 37? lol I need some ideas since saying that I want to jailbreak it and unlock it doesn't sound like a good idea!
     
  10. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #10
    Apple & AT&T are applying the 3.1 firmware update to every 3GS which leaves the store.
     
  11. self thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #11
    Ouch. I wonder if they're trying to be helpful or if you can specifically request that it *not* be updated to 3.1.

    @CK- Actually yes, I was just going to tell them I wanted the option of being able to jailbreak. Doesn't seem like an individual employee would care. Let me know if you can think of anything better...
     
  12. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #12
    I doubt it's to be helpful. Same reason Apple dropped the signing on 3.0 and 3.0.1 IPSW's for 3GS. You can only select 3.1 if you have a 3GS.

    They are trying to stop JB & UL.
     
  13. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #13
    Any word on if AT&T stores will do the same thing?
     
  14. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #14
    Just got back from the AT&T store and guess what...they didn't upgrade the firmware on my iPhone! :D

    Now time to go JB/Unlock this thing...
     
  15. self thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #15
    Thanks for the info CK! I'm leaving for the Apple store soon and if that doesn't pan out I'll head to AT&T.

    What week is your phone (from serial number on the back)?
     
  16. California King macrumors 65816

    Joined:
    Sep 20, 2007
    #16
    Good luck! It's week 35
     
  17. aarong50 macrumors regular

    Joined:
    Aug 22, 2009
    #17
    We just bought my wife a 3gs yesterday (12th) and it had 3.1 preinstalled.
     
  18. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #18
    Wow, that was quick. :(
     
  19. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #19
    go to best buy or Wal Mart and try...im sure they'll keep it on 3.0
     
  20. self thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #20
    Back from AT&T. We got 3 phones with 3.0.1 installed (decided to just get 3 phones instead of 4). 1 is week 35 and 2 are week 36.
     

Share This Page