Dear Apple: Please fix my wireless you broke with 10.6.5

Discussion in 'macOS' started by phil1995, Jan 9, 2011.

  1. phil1995 macrumors member

    Joined:
    Aug 4, 2008
    #1
    Well, another update has come out (10.6.6.) and I cant even upgrade to use the app store. I have tried for the 5th time with the same results and have reverted back to 10.6.4.

    Does anyone have any idea how to solve the problem of intermittent drop outs on the wireless for anything above 10.6.4?

    10.6.4 works perfect, so I know its not my router, its a software issue.
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    Have you done the combo update instead of the smaller one that shows up in Software Update?
     
  3. pcconvert macrumors member

    Joined:
    Oct 24, 2008
    #3
    I had wireless problems on my late 2008 alu MBP17. Latest update of airport express released in December caused various problems. Reverting back to earlier release put me back on track. Lookup the archived releases on apple support pages.
     
  4. phil1995 thread starter macrumors member

    Joined:
    Aug 4, 2008
    #4
    Yes, I have done the combo update along with millions of suggestions from various websites. Nothing seems to matter except taking it back to 10.6.4
     
  5. phil1995 thread starter macrumors member

    Joined:
    Aug 4, 2008
    #5

    I am not familiar with airport express. Is this only if I am using the Apple router?
     
  6. phil1995 thread starter macrumors member

    Joined:
    Aug 4, 2008
    #6
    I spent about 3 hours in the Apple store at the genius bar yesterday with this issue. They ran all the diagnostics and did not have a clue what was causing the issue. They finally told me that I need to replace my wireless card, and if that does not work, replace the logic board.

    I ran a test of my own when I got home. I formatted an external USB drive and loaded a fresh copy of snow leopard onto to it and booted into that drive. I then ran all of the updates and brought it up to 10.6.6.. It worked fine for about an hour, then started dropping the wireless again. Once again, I dropped it back to 10.6.4 and all of the issues magically disappeared.

    Does it make sense to anyone that this could be a problem with my wireless card or the logic board when it works fine on 10.6.4? Just makes no sense to me and I am reluctant to start speding money replacing hardware when there are no hardware issues on 10.6.4, just updates beyond that.

    I also tried skipping the last airport update 5.5.2 when updating to 10.6.6, this made no difference either.
     
  7. Damo01 macrumors regular

    Joined:
    Feb 11, 2010
    Location:
    Australia
    #7
    What's actually is your problem with your wireless?
    Can you not connect to wireless access point or router?
    Have you tried deleting the plist files?

    Need more description of your wireless problem than just saying "wireless problem".
     
  8. SavMBP15 macrumors 6502

    Joined:
    Mar 26, 2010
    #8
    Its not the software. No one really knows what the problem is. I had the problem with 10.6.4 and now it works fine on 10.6.5 and 10.6.6
     
  9. jiffle macrumors newbie

    Joined:
    Jan 30, 2011
    #9
    Definitely a software problem

    Definitely a software problem - have it on 3 computers: MB, MBP. MacMini. Reverting the MB to 10.6.4 fixed the problem completely.

    Issue seemed to be related to order of joining the network, with one computer being fine, while the other had issues and then they swap over later in the day. Updating to 10.6.6 seems to have made the issue occur less often but, given the erratic nature of the problem as mentioned earlier, I cannot be certain.

    Tried Combo Update, Airport Express update, no joy.

    All computers are older 801.11g. Both Airport Expresses (extended network) and 801.11n/g. The base AE is set up to bridge to my wired network.

    Issue is difficult to pin down - DNS fails while IP addresses remain available, however downloads also fail half way through, for some inexplicable reason

    BTW: MacRumors wins an all time award for crap forum software: 3 attempts to register (each time bounced by the captcha and forgetting the password and time zone), and then it logged me out losing my 1st sending of this post... Geez
     
  10. jiffle macrumors newbie

    Joined:
    Jan 30, 2011
    #10
    Plist

    Plist files? Which ones... or should I pick some at random and delete them in some great Plist Jenga game?
     
  11. Damo01 macrumors regular

    Joined:
    Feb 11, 2010
    Location:
    Australia
    #11
    No I wouldn't randomly pick them because that might cause more problems. I'm not sure this will fix your issue, but I do know that some plist files can cause problems and can be fix by deleting them. Although the plist files will be re-created once you delete them.

    Go to Macintosh HD -> library -> Preferences -> System Configuration
    and remove the airport.plist files.
     
  12. phil1995 thread starter macrumors member

    Joined:
    Aug 4, 2008
    #12
    It is in fact a software problem. I have resolved the issue by replacing the 10.6.6 airport driver with the driver from 10.6.4.

    I have been running for about 3 weeks or more on 10.6.6 with the reverted driver now with not one issue regarding my wireless.

    I have proven, that in my case, it was in fact a software issue directly related to the Update begining with 10.6.5.

    If anyone would like to know how to revert back to the 10.6.4 driver to try this for themselves, I will gladly fill you in on how to do that.
     
  13. Doud macrumors newbie

    Joined:
    Feb 8, 2011
    Location:
    Paris
    #13
    Hi everyone, I have the same issue, connection times out each time I try to connect via wireless. I can't find a way to revert back to the old version of the airport driver without reinstalling SL. Phil if you have more information on how you do this I'd appreciate.
     
  14. phil1995, Feb 9, 2011
    Last edited: Feb 9, 2011

    phil1995 thread starter macrumors member

    Joined:
    Aug 4, 2008
    #14
    Here is a cut and paste from another forum where I learned how to do this. Like I say, it has completely solved all the wireless issues I was having after the 10.6.5 update.

    Big thanks to the user tenortim for this valuable info.

    http://discussions.apple.com/thread.jspa?messageID=12924009&#12924009


    OK, my wife just went through this ordeal (2007 MBP, Atheros 5424 chipset).
    Thanks to the work of others diagnosing this, I found a solution that doesn't require a full downgrade, although a little bravery might be needed.

    As has already been stated, the version of the firmware for the Atheros cards changed in 10.6.5. This seems to be the culprit. Did anybody bother testing this fully? The new firmware is unable to maintain a connection under conditions that the older firmware handles with aplomb. Anyway, we clearly need the older driver/firmware, but downgrading to 10.6.4 seems rather draconian, so I set about finding a solution that just fixed that problem.

    To cut to the chase, you can run the 10.6.4 drivers on 10.6.6. To do so,
    1) Download the 10.6.4 Combo update and the Pacifist program that allows one to extract files from, amongst others, ".pkg" files.
    2) Mount the update .dmg, open the package in pacifist, extract the subtree "/System/Library/Extensions/IO80211Family.kext" to a convenient location.
    3) As root, cd to /System/Library/Extensions, rename IO80211Family.kext to IO8021Family.10_6_6 (or anything else to back it up), and copy in the replacement IO80211Family.kext that we extracted from 10.6.4.
    4) Download, install and run "Kext Utility" (Google it, it's at Insanely Mac). It should ask for your password, run, and fix up the kext permissions and caches.
    5) Reboot. You should now be on the new (old) driver/firmware. Verify by running "About this Mac" -> "More Info" -> "Network" -> "Airport". As stated, the newer firmware is 2.1.14.5, the working firmware is 2.0.19.10.

    After doing this, my wife's MBP is back to full functionality and domestic harmony is restored. Apple, please revert this driver and inform Atheros that it does not work correctly.

    Message was edited by: tenortim (fix typos)
     
  15. phil1995 thread starter macrumors member

    Joined:
    Aug 4, 2008
    #15
    Update:

    The trick with switching the wireless drivers has worked without fail. However, I have serious doubts that this will work when the switch to Lion is made.

    I ordered a new wireless card, just to see if that could be the problem. The card I received, was identical to the one I currently had in the machine (an atheros based card). I replaced the card, and ended up with the same results (big surprise huh).

    I then replaced my atheros card with my original Broadcom card (thats another story), and lo and behold, I no longer have the wireless issues.

    I am now running 10.6.7 with no wireless issues what so ever. If you have an atheros based card and are experiencing this problem, try swapping the card for a Broadcom based card and see if your issues are resolved.
     
  16. jiffle macrumors newbie

    Joined:
    Jan 30, 2011
    #16
    10.6.8 The Trick?

    Hi all,

    Have been regularly updating the OS version on two of the affected machines, while the wife's I've left on 10.6.4.

    Things do seem vastly improved since the update to 10.6.8. The Mac Mini had been unusable on all versions since 10.6.4 (even running an upgrade was tricky as the connection would rarely last long enough for the download). Since the update, however, I've been able to run iPlayer downloads and everything seems fine.

    Now all I have to do is to update the wife's computer (dons flack jacket in case it goes wrong!)

    David

    PS: @Damo01: Deleting PList files didn't work. In fact it briefly broke all connectivity until I restored some of them.
     
  17. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #17
    It would do, as that's the whole point.

    Deleting the plist is deleting the settings, so you have to start from fresh. :rolleyes:
     
  18. jiffle macrumors newbie

    Joined:
    Jan 30, 2011
    #18
    Really? You don't say? (Shakes head)

    Yes, deleting plist file clears settings, but I was surprised by the number of settings items that were deleted.

    And, more to the point, it didn't solve the problem.
     

Share This Page