Dear God.. What did I do? MBA HDD Issue.

Discussion in 'MacBook Air' started by Abyssgh0st, Dec 28, 2009.

  1. Abyssgh0st macrumors 68000


    Jan 12, 2009
    Norman, OK
    With the problems with my RunCore drive found here, , I've decided to return the drive, sell my MBA, and get an iMac. So after my installation woes from installing the RunCore, I've became pretty educated in installing/removing drives with the MBA, but this has me stumped.

    Keep in mind, when I installed the RunCore SSD, I never formatted my HDD or anything. It should be exactly how I left it before installing the RunCore.

    So I took out the RunCore SSD, and simply re-inserted my HDD back into my MBA just like I had done during my installation (due to the drive not being bootable and me having to re-clone the SSD), and now when I have the HDD back in I get the nefarious folder with the question mark. This is what I have tried so far:

    1. Countless computer restarts and PRAM resets with the HDD in.
    2. Trying to install Snow Leopard via disc in the external SuperDrive, and then trying to start the installation, to which OS X recognizes no drives to install Snow Leopard on.
    3. Getting into the Snow Leopard install screen, then I choose disk utility, yet it does not recognize the drive at all.
    4. Booting using countless commands, Command+S, Command+V Command+Option+Shift+Delete, Command+Shift, etc.
    5. Checked the two SATA connectors that plug into the logic board, obviously the larger one works as the RunCore SSD still boots.
    6. Re-inserted the LIF cable that goes into the HDD just to make sure it was in all the way.
    7. With the PCB included with the RunCore I tried connecting the HDD externally via PCB+USB cable, and it does not show up as I have a bad PCB connector (I knew this before this ordeal).
    8. Connecting the PCB+USB+HDD to a PC, and get no results. Windows fails to install the 'drivers' for the PCB.

    One extra kink in the puzzle: When I had to re-insert the stock HDD during my initial installation of the RunCore SSD (about a week ago), I had not ever tried connecting the HDD to the PCB and it booted up fine. Is there any way the PCB could have fried my drive?

    Also keep in mind; that during this process I have re-inserted the RunCore SSD many times (once to backup my whole drive via Time Machine, just to be safe), and it boots up (most of the time, if it doesn't give me the folder with the question mark error on bootup *see link at top of the page*) like it should. Then immediately after that I re-insert the HDD, I get the same error.

    So essentially OS X doesn't recognize the seemingly untouched stock HDD, nor does it by Disk Utility.

    Please someone help.. I am totally at a loss here.

Share This Page