December 2007 black Macbook will not get past spinning gear and shuts down after abit

Discussion in 'MacBook' started by rafecohan, Dec 6, 2009.

  1. rafecohan macrumors newbie

    Joined:
    Dec 6, 2009
    #1
    Hello All,
    this is my first post as it is the first time i haven't found specific answers elsewhere.

    My Macbook will go to the grey screen with logo and gear for 30 seconds and i have tried the following.

    I have tried to reset the ram with the command function i forget the keys like p r or something, and i finally got the bong noise.

    this still didnt help so i tried to get into safe after this noise with the left shift key, and once i let go at the gear, it still shut down after around half a minute 45 seconds.

    I then booted into verbose to see what was really causing this shut down after this.

    this was the last couple of lines it froze up on before shutting down.
    ............................................................................................

    [HCIController][configurePM] power parent ready after 1 tries
    [AppleIntelCPUPowerManagement: initialization complete
    disk0s2: I/0 error.
    disk0s2: I/0 error.
    syncing disks... killing all processes



    continuing
    done
    CPU halted
    ............................................................................................

    it usually freezes on the line disk0s2:I/0 error for about a mintue, and once the last run from the second I/0 error to the CPU halted rolls onscreen it is around 3 seconds before it shuts down.

    For the last i dont know 3 weeks i have gotten every once in a while these messages saying my startup disk was full, even though i had 37 gigs left on the hard drive.

    the reason i got here was because i was trying to copy some files from my compact flash recorder to my computer for listening and maybe 10 of the 15 copied and said the rest could not be transferred because of the disk being full. At this point i decided to restart, and it would not come back to desktop. ANY HELP anyone?

    thank you so much
     
  2. mperkins37 macrumors 6502a

    mperkins37

    Joined:
    Jan 17, 2007
    Location:
    Phoenix, AZ
    #2
    Sounds like a case of Dead or seriously damaged HD. Did you drop the computer recentlty, or have it get shut down unexpectedly due to power loss.
    I would say the HD is suspect.
    Lucily they're relatively cheap.
     
  3. macuserx86 macrumors 6502a

    macuserx86

    Joined:
    Jun 12, 2006
    #3
    Had a similar problem with a friend's MacBook unibody (it was showing !folder on post) and I fixed it by re-seating the HDD, which had come loose. Try doing this, but I make no guarantees as you may have a dead HDD.

    Hope that helps!
     
  4. drtech macrumors newbie

    Joined:
    Dec 7, 2009
    #4
    This sounds like a failing hard drive. The I/O error above refers to "disk0s2" which means the second partition (s2) on the first installed hard drive (disk0) cannot be read.

    The fact that you get to the grey screen is actually a good sign. That means that the Mac can at least still see that a hard drive is installed. In many cases, the drive is so badly damaged that the Mac doesn't even recognize that a drive is installed. However, time may be short, as extended use will often cause additional damage which may preclude taking a backup or even recovery.

    Right now, you probably are looking at replacing the hard drive, installing a fresh OS and restoring from a recent backup. You can try connecting the bad Mac to another Mac using target disk mode to see if you can get any files off at all.

    To do this, power the old Mac while holding down the "T" key. When the FireWire symbol appears on the screen, connect the Mac to another Mac using a FireWire cable. Hopefully the Mac's drive will appear on the Desktop and you can try to copy important files. If not, you can try a repair in Disk Utility.

    [​IMG]

    However, take caution. If the drive stalls or takes too long to copy, then this is almost certainly a failing hard drive. Allowing it to run for an extended period can cause the damage to get significantly worse.

    Jeff
     

Share This Page