Dedicated Card Not Turning Off.

Discussion in 'MacBook Pro' started by Benjones-KY, Apr 30, 2010.

  1. Benjones-KY macrumors member

    Joined:
    Apr 16, 2010
    #1
    I've tried rebooting, closing out of all applications. The card stays on. I recently downloaded a program called Cinch which does the same thing as Windows side by side feature. I disable Cinch and the card still stays on. Anyone else having this problem? Or maybe someone else can download Cinch and see if that's the cause. Any help would be appreciated.

    Apple really needs to give us the option to set programs that turn the card on. Google Chrome and Skype? Reeeaaallyy?
     
  2. VaderMonkey macrumors newbie

    Joined:
    Jan 12, 2010
    #2
    I had the same problem with my 2010 MBP and found it was MagicPrefs for my magic mouse that was triggering the nVidia.

    This Terminal command line will tell you what's using it. It must be run in zsh.
    ps cx | egrep $(echo ${$(ioreg -l | grep task-list | sed -e 's/(//' | sed -e 's/)//' | awk ' { print $6 }')/','/'|'})

    Credit to bitninja for the command and for his handy program telling you which card is being used. (http://codykrieger.com/gfxCardStatus/)
     
  3. MindlessJD macrumors member

    MindlessJD

    Joined:
    Apr 19, 2006
    Location:
    Hampshire, UK
    #3
    I'm guessing as it's new technology for Apple that they will probably release an update for it soon enough. That's usually how they roll.

    On a side note, does the NVIDIA card significantly reduce battery life when it won't disable then?
     
  4. tekmoe macrumors 68000

    Joined:
    Feb 12, 2005
    #4
    I was having this same exact problem. I couldn't figure out what was keeping the Nvidia gfx enabled so I ended up reformatting and reinstalling the OS. Applecare was no help; they couldn't give me any advice as to how to figure out what was causing it to stay enabled.
     
  5. Benjones-KY thread starter macrumors member

    Joined:
    Apr 16, 2010
    #5
    I found out it was Cinch keeping it on. I turned it off, but didn't exit the little icon. The hit in battery life is 4 or so hours I would guess.
     

Share This Page