Default Browser Changed After Reboot

Discussion in 'Mac Basics and Help' started by revenent, Jul 26, 2008.

  1. revenent macrumors regular

    Joined:
    Jul 26, 2008
    #1
    Ok i know this may have been asked before but i simply cannot find a correct answer to it.

    I have the Mac OS 10.5 and its default browser is Safari. So i installed Firefox 3 and set it as the default browser in both Safari and checked the "Always check if firefox is the default browser" checkbox in firefox itself. Everything works ok until i reboot. I have to keep doing this all the time.

    Sorry if i sound dumb but is there a way to like permanently set Firefox to be the default all the time even after rebooting it instead having to go through all those steps highlighted above. And i also dun like it when everytime i open firefox after i turn on my MBP i have to always click "OK" everytime firefox checks if its the default.

    Thanks very much. (Please dun tell me to go back and use windows ala some other forums)
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    Remove the check from "always check......... in Firefox. Once you set Firefox as the default browser in Safari's options there's no need to set Firefox to "always check....." because that's exactly what it'll do each and every time.

    Regards.
     
  3. qacjared macrumors regular

    Joined:
    Jan 28, 2008
    #3
    Safari's Preferences
     

    Attached Files:

  4. revenent thread starter macrumors regular

    Joined:
    Jul 26, 2008
    #4
    I have tried those 2 settings which you have advised. In safari, choose firefox as the default browser. In firefox, uncheck the "

    Always check if firefox is the default".

    Problem is, after i reboot the whole mac, everything goes back to default i.e Safari is the default. When i check in safari, the default browser goes back to safari and i have to select firefox again.

    Any suggestion?
     
  5. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #5
    try first do a reset of safari, and delete its plist (spotlight search for it). then set firefox a default in safari.
     

Share This Page