Default calendar for new iPhone events..setting not there

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TheShocker, Jun 21, 2009.

  1. TheShocker macrumors member

    Joined:
    Nov 29, 2008
    #1
    Hey guys,

    Not sure if this is normal behavior, as I am a new iPhone user as of Friday. I have 6 calendars in iCal (which are synced to Google Calendar) that I sync to my iPhone via the cable each night. (I tried CalDav and Exchange but I'm not happy with how either of these worked. MobileMe is not an option, nor are 3rd party apps.)

    I want to specify which calendar new events created on the iPhone are assigned to, and I want these newly created events to sync back to iCal when I connect my iPhone to my MacBook. As it is right now, iPhone creates a new calendar named "Calendar" which does not sync back to iCal. A quick Google search explained how to do this, but I do not have these settings in iTunes or on my iPhone...

    1) In iTunes, under the Info > Calendar section the "when creating new events on the iPhone, use this calendar" option is not there.

    2) In iPhone settings, the option for default calendar (at the bottom of the Mail, Contacts, Calendar menu) is not there.


    Can anyone explain how to do this using a default calendar? Or, even better, is there a way to specify which calendar a new event is assigned to for each new event (such as, work, school, etc.) on the fly, like in Google Calendar?
     
  2. sonictonic macrumors 6502a

    Joined:
    Mar 25, 2006
    Location:
    Central Coast, California
    #2
    It's there for me... under Settings - Mail, Contacts, Calendars. The last option is "default calendar."
     
  3. TheShocker thread starter macrumors member

    Joined:
    Nov 29, 2008
    #3
    I'm trying to figure out why mine is not there
     
  4. sonictonic macrumors 6502a

    Joined:
    Mar 25, 2006
    Location:
    Central Coast, California
    #4
    I'm sorry lol yeah to be honest I think it's because your calendars are subscribed. I think it only gives you the option if they are iCal native calendars. I'm pretty sure that's the reason...
     

Share This Page