default email app

Discussion in 'Mac Apps and Mac App Store' started by gunner, May 29, 2007.

  1. gunner macrumors newbie

    Joined:
    Jun 12, 2006
    #1
    I'm using firefox to surf the web and recently installed the google toolbar. When it asked me if I would like to set gmail as my default email client, I made a mistake and said yes. Now whenever I click on a mailto link, it opens gmail in another tab. I do not like this.

    Can anybody tell me how to set Apple Mail as the default again? I much prefer that program.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I believe, inside Apple Mail, there is an option for setting the default Mail program. I don't know exactly where it's located, since I'm not at a Mac right now.
     
  3. gunner thread starter macrumors newbie

    Joined:
    Jun 12, 2006
    #3
    I just tried that, and it's still listed as Mail. When I click a mailto link in safari, mail opens, but in firefox it goes to gmail, which is making me think that this is a firefox problem...
     
  4. janey macrumors 603

    janey

    Joined:
    Dec 20, 2002
    Location:
    sunny los angeles
    #4
    try in google notifier preferences - Compose mail in: ...
     
  5. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    In that case, the cause is almost certainly in the type handlers configuration for Firefox. Open up Preferences, find where it says something like File Actions, and open that up. There should be an entry for mailto: URLs with GMail listed as the handler. Delete that, and your problem should go away.
     
  6. gunner thread starter macrumors newbie

    Joined:
    Jun 12, 2006
    #6
    I've looked in the google preferences, I didn't see anything there that could help me.

    In Firefox prefs, under file actions, the only two options are for PNG and TIFF files.

    So, I uninstalled google toolbar and then when I clicked a mailto link, absolutely nothing happened.

    Then I uninstalled Firefox and deleted the mozilla folder from the library, but when I reinstalled firefox, all of the old settings were still there.

    This is getting frustrating.
     
  7. hopejr macrumors 6502

    Joined:
    Nov 10, 2005
    Location:
    New South Wales, Australia
    #7
    EDIT: My bad, should read the whole thread in detail, instead of skimming it.
     
  8. gunner thread starter macrumors newbie

    Joined:
    Jun 12, 2006
    #8
    OK, I fixed my problem. I just had to nuke my profile in the firefox settings. Now I'm off to rebuild what I had. Fun!
     
  9. bokdol macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
    #9
    just so you know. if you open both safari and the apple mail app. go to preference and select the general tab. this is where you can select which app will be the default app for mail and web browsing.you can change it any time here.
     
  10. gunner thread starter macrumors newbie

    Joined:
    Jun 12, 2006
    #10
    I appreciate the tip, but that solution was offered and tried and did not work. Google toolbar changes something else, and I've yet to find a way to fix it without deleting the firefox profile.
     
  11. skwij macrumors 6502

    Joined:
    Apr 10, 2006
    Location:
    Belleville, ON, Canada
    #11
    In future, just MOVE the Firefox profile to the desktop, restart Firefox, and a new profile will be created. Then reimport the settings you want into the new profile, from the moved/desktop profile (alternately, move the old profile to the Trash, but do NOT delete the trash).

    Another hint>

    Type about:config in the address bar in Firefox. That will open a window/tab with a slew of options. Filter on "mailto" and reset all those values to default.

    Google toolbar has been nothing but problematic since Firefox 2.0; it may be worth removing it as well.
     
  12. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #12
    I realize this thread is a year old but I just encountered the same problem in Firefox of all mailto links automatically routing to the G-Mail site. I saw that some in this thread resorted to nuking their Firefox profiles to cure the problem and I wanted to say that's probably not necessary.

    Check your extensions. In my case it was a setting in the Better GMail 2 extension which by default converts all mailto links to open at the G-Mail page. All I had to do was uncheck the setting in the extension's preferences.

    It was annoying, to say the least, to have every mailto link open at G-Mail's site when all I need was Mail.app to open them.
     

Share This Page