Default External HDD not showing up in Snow Leo.. possibly ejected improperly. help

Discussion in 'Mac Basics and Help' started by th3g1z, Feb 26, 2010.

  1. th3g1z macrumors newbie

    Joined:
    Apr 3, 2008
    #1
    So I'm no expert to mac's.. and I'm having some troubles that I hope someone could help me figure out. There are cliffs at the bottom if you don't want to read the whole post.

    I have a 2TB external HDD (WD MyBook) connected via FireWire to my Mac Mini
    It is configured in RAID 1, mirroring.

    EDIT: After running Repair Disk from DiskUtility I got this message: "Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files."

    I have had it connected for a few months now, used it as my Time Machine drive, and for an assortment of other backup stuff as well.

    The other day I needed to transfer some larger documents to another computer, and my (dumb) self didn't eject the drive properly from within Snow Leopard first, I just yanked the cable out of the machine.

    Well of course SnowLeo error popped up saying that I had ejected it improperly but it would try to fix everything the next time I plugged it back in.

    I plug it back in it would not come up as a drive, so I try and unplug/replug a few times and I forget the error it said but something to the effect of it had tried to mount it 3 times and that there may be data loss, also it mentioned it would show up as a Read-Only drive so that I could back up data and then I guess reformat the drive. Well I click on the MyBook drive icon (It showed up as a folder rather than as the Time Machine icon). And I was not able to see anything, just the little thing that spins in circles while the drive is thinking at the bottom right.

    So I power the thing down again and rebooted my mac a few times too just to see if it would help, and no it didn't. Now the drive doesn't even show up as a folder or anything for that matter, the icon has just disappeared.

    I've attached a screen shot with some stuff I was poking around in trying to figure out where my drive went, so there is a screen shot with DiskUtility (the drive appears there but it is grayed out), also went to terminal and did a "diskutil list" and it sure enough is listed in there disk2s2. Also a screen shot of my other drives which are listed just fine in finder. and also I have the Western Digital Drive Manager software up showing that the drive is configured and "healthy" and also the info from About this Mac specifically the USB section so the drive details are shown (oh yea, I switched between FireWire and USB a few times to see if that would make my drive come back.. but no that didn't work either)

    Screen shot: http://imgur.com/Hk4Lj.png

    So if anyone can help I would be super super happy! Because its a 1TB drive almost 3/4 filled up with all kinds of stuff I would really like to have backed up.. considering it is my backup drive.

    I figure worst case scenario I will pull the drive out of its little western digital shell and figure out a way to retrieve the data that way.. but I would much rather not have to do that.

    Cliffs
    Drive was not ejected properly and just pulled out
    Drive showed up as a Folder instead of drive icon
    Gave me an error
    Drive icon disapeared
    Screenshot with some of the stuff I've looked into.

    Thanks to anyone who can help
     
  2. Electro Funk macrumors 65816

    Electro Funk

    Joined:
    Dec 8, 2005
    Location:
    The Opium Garden
    #2
    sorta the same thing happened to me, although i have 3 x1 Terabyte drives and 2 x 500 gig drives ~ All External (and a few old TI PowerBook drives that i threw in some cases, one is 40 gigs and was the max you could get at the time i think. still runs almost as fast as the newer drives!:cool:)

    Anyway, i have one of the 1 TB drives hooked up firewire to the iMac and is backing that up. the two 500 gigs and the other 1 TB external (and TI PB HDs) are hooked to my AEBS and one wirelessly backs up the wife's black MacBook, the other backs up my Unibody MBP. The 1 TB is for misc.. stuff and the older drives are just for space to store some extra things.

    anyway, the external that backs up my MacBook Pro stopped mounting and refused to mount and back up for a few weeks ~ close to a month. tried all the tricks and nothing was working. getting annoyed as i was, i was poking around at them and accidentally pulled out the USB connector for that drive. then thought DOH!

    Got the same message in disk utility. after several attempts to fix with no success, i ended up plugging it straight into my iMac and erasing everything (reformat). ended up working and is now backing up my MBP wirelessly again, although i lost a good year of backups. (Although, anything important is still on my machine or on one of the other drives)

    what a hassle though. i hope you can recover the files you have on there. thankfully i had all my info backed up as well with another program (just not all the changes that time machine does)
     

Share This Page