Default font in Mail and Notes is still Helvetica?!

NauCayuti

macrumors member
Original poster
Oct 19, 2014
47
6
I recently updated my MacBook from the latest Yosemite version to the El Capitan public beta. In many screenshots I saw, San Francisco was the default font for the body text of mails and notes. While menus, sidebars, etc. are correctly set in San Francisco for me, the body text of my mails and notes is still set in Helvetica (Neue). Any idea what might be the problem?

Thanks!

P.S.: As San Francisco does not appear in my font book – that seems to be normal – I also can't change it in the application itself.
 

NauCayuti

macrumors member
Original poster
Oct 19, 2014
47
6

fisherking

macrumors 604
Jul 16, 2010
7,053
1,949
ny somewhere
Actually, I don't think so. Take a look at screenshots such as this one:
http://cdn.osxdaily.com/wp-content/uploads/2015/06/os-x-el-capitan-new-font.jpg

The body text is set in the same font as UI and the message list.

The same goes for Notes:
http://cdn.arstechnica.net/wp-conte...een-Shot-2015-06-12-at-6.46.29-PM-980x647.png
and regardless of those shots, San Francisco does seem to be reserved for the UI, and not available in apps (as leman pointed out)...
 

NauCayuti

macrumors member
Original poster
Oct 19, 2014
47
6
and regardless of those shots, San Francisco does seem to be reserved for the UI, and not available in apps (as leman pointed out)...
I'm not quite sure what you mean with "regardless ...". The font is shown as the default font of e.g. the new Notes app both in many screenshots and videos. It might not be available in third party apps, fair enough. But how else would you explain these shots?

As for a video:
 

fisherking

macrumors 604
Jul 16, 2010
7,053
1,949
ny somewhere
I'm not quite sure what you mean with "regardless ...". The font is shown as the default font of e.g. the new Notes app both in many screenshots and videos. It might not be available in third party apps, fair enough. But how else would you explain these shots?

As for a video:
meaning, regardless of what might have been, this is how it actually is. not hard to understand, but..you have to decide to accept it. apple may have considered using the font in it's apps, then changed it's mind. so it goes...
 

NauCayuti

macrumors member
Original poster
Oct 19, 2014
47
6
No problem with accepting that, don't worry. Maybe you misunderstood me as nagging about Apple's decision to abandon San Francisco for body text in their apps (I would be unhappy about that decision if it actually was one). Actually, I was wondering whether it could have been some local problem on my machine, as I had been tinkering with system fonts in previous OS X versions. Thought so especially due to the abundance of screenshots showing the body text as San Francisco ... If Apple decided to go with good old Helvetica -- so be it.
 

fisherking

macrumors 604
Jul 16, 2010
7,053
1,949
ny somewhere
i hear you. i tried changing fonts to SF a while back as well, and realized the font was, in fact, not available. ah well...looks good in notes, and mail (in the mockups). but helvetica is still a great font too.
 

Superhai

macrumors 6502
Apr 21, 2010
452
359
I am not sure when upgrading, but on new installations of El Capitan GM, the list font is in the "System Font" (a.k.a. SF), body and fixed-width are Helvetica and Menlo. For some reason on some computers I am not able to change the list font, but on others I am able to, but then it is not possible to change it back to "System Font" (at least not from the GUI).
 

navaira

macrumors 68040
May 28, 2015
3,799
4,975
Amsterdam, Netherlands
Sorry to revive this thread but it looks like this has been a problem since Lion (!) and I can't find a solution...

Is there a way to increase size of the message list font? Terminal doesn't scare me, I'm willing to install external apps, this is just too damn small for me. The setting is conveniently disabled unless I use classic view.
 

fisherking

macrumors 604
Jul 16, 2010
7,053
1,949
ny somewhere
Sorry to revive this thread but it looks like this has been a problem since Lion (!) and I can't find a solution...

Is there a way to increase size of the message list font? Terminal doesn't scare me, I'm willing to install external apps, this is just too damn small for me. The setting is conveniently disabled unless I use classic view.
it's frustrating, there seems to be no way to globally (in Notes) choose a font size (or alphabetize, but that's another issue). what's crazy is, i bumped up the font size for all my notes on my mac (one-at a time), and the font size got SMALLER on my iphone... :rolleyes:
 
Last edited:

KALLT

macrumors 603
Sep 23, 2008
5,062
3,082
The setting is conveniently disabled unless I use classic view.
No Terminal command. The message list with sidebar-style never supported variable font sizes. What you can do is disable the custom markup of the message list and force it into the same style as the classic-style message list:
Code:
defaults write -app Mail RichMessageList -int 0

This obviously doesn't look nice, so you have to make it wider. You can hide certain columns with View > Columns.


––

On topic: one of the reasons why you can't freely choose your mail typeface is because Mail will attempt to use that typeface in rich-text messages. It is very unlikely that your recipient has the same typeface available, which means that it will show their default typeface instead. Depending on their email client, you will likely get a message back that has a predefined typeface as well. In other words, using San Francisco here is not helpful. This is different from applications like Notes, because you will only ever see this formatting on your Mac or iOS devices anyway.
 
Last edited:

navaira

macrumors 68040
May 28, 2015
3,799
4,975
Amsterdam, Netherlands
Hi,

maybe I don't understand something but this just switched me into Classic view...?

Edit: Ah, I figured out what happened. I don't like the result though :( Maybe I'll give Thunderbird a chance again.

Good explanation with why San Fran is not the default font for messages, I wouldn't think of that.
 

NauCayuti

macrumors member
Original poster
Oct 19, 2014
47
6
On topic: one of the reasons why you can't freely choose your mail typeface is because Mail will attempt to use that typeface in rich-text messages. It is very unlikely that your recipient has the same typeface available, which means that it will show their default typeface instead. Depending on their email client, you will likely get a message back that has a predefined typeface as well. In other words, using San Francisco here is not helpful. This is different from applications like Notes, because you will only ever see this formatting on your Mac or iOS devices anyway.
But then why is San Francisco the default font for Mail on iOS 9? Shouldn't the same caveats apply there?

By the way, I changed my default mail font to PT Sans from ParaType. Very nice sans serif with a good default linespacing. Still, I'd prefer to have a consistent appearance across devices.
 

Planey28

macrumors 6502
Jul 10, 2010
449
529
Birmingham, UK
Notes used SF in beta builds of El Capitan and it changed to Helvetica Neue in a later build - seems to be a mistake/bug as it is completely inconsistent (even iCloud.com uses SF in notes now) and you can't change the font in Notes.

Hopefully an update fixes this, SF is a much more readable and pleasant typeface and Helvetica sticks out like a sore thumb in Notes to me now (admittedly, I'm a graphic designer and most people won't notice or care!)
 
  • Like
Reactions: navaira

KALLT

macrumors 603
Sep 23, 2008
5,062
3,082
But then why is San Francisco the default font for Mail on iOS 9? Shouldn't the same caveats apply there?
I don't know. Perhaps they offer it there, because you can't change the typeface anyway. On OS X, Mail uses the standard font picker that cannot access San Francisco.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.