Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

7enderbender

macrumors 6502a
Original poster
May 11, 2012
513
12
North East US
Hello Everyone,

I'm new to Mac but I'm an experienced computer user and have been doing a lot of catch up with OS X over the last few days since my new Mac Mini came.

Here's one that I haven't found a solution for: The Mini is connected to an external audio device (Lexicon Lambda for recording and audio out) and also to my new Logitech C920 web cam which has a microphone also.

What happens now in FaceTime is that after every reboot I have to manually select the mic for the camera. I haven't found any setting yet to pick a default mic, neither globally nor for FaceTime in particular.

If there is no regular setting for that can anyone think of a workaround?

Thanks!
 

FreakinEurekan

macrumors 68040
Sep 8, 2011
3,451
424
Eureka Springs, Arkansas
The global setting is in Apple menu > System Preferences > Sound then click Input at the top.
 

Attachments

  • Screen Shot 2014-01-04 at 7.48.11 PM.png
    Screen Shot 2014-01-04 at 7.48.11 PM.png
    63.3 KB · Views: 701
Comment

7enderbender

macrumors 6502a
Original poster
May 11, 2012
513
12
North East US
This is still an ongoing issue for me. The default setting in FaceTime still randomly switches over to my firewire audio recording device.

Is there anywhere else where I could set a permanent default microphone for FaceTime? There is no need for FaceTime to even consider my outboard audio unit.
 
Comment

SpiceWare

macrumors newbie
Jan 23, 2014
4
0
Houston
Still does it. Anyone?

Did you find a solution? I work from home and have a couple monitors set up for my work computers. I used to have my MacBook Pro (late 2008) on my desk and connected it one of the monitors via a KVM. I'd use the laptop's display as a secondary monitor and for FaceTime.

I recently got a Treadmill Desk (my blog entries about it if anybody's interested) and no longer have room to put the MBP on the desk. So I'm now using it in clamshell mode (lid closed) and picked up a Logitech C920 to stick on top one of the monitors.

Under System Preferences->Sound I changed my default audio input from the internal microphone to the C920. I also changed FaceTime via its Video menu to use the C920 camera and C920 microphone.

If I quit FaceTime and relaunch it the C920 camera and microphone stay selected. I shut down my computer each night. When I start it up in the morning, FaceTime remembers the C920 for the camera but switches audio back to the internal microphone.

The internal microphone doesn't work very well as the lid's closed and the laptop is 4-5 feet away.
 

Attachments

  • IMG_4558.JPG
    IMG_4558.JPG
    1.5 MB · Views: 330
Comment

enigma2k

macrumors regular
May 12, 2010
188
58
I have the same issue that Facetime always switches to my external soundcard microphone after each reboot. Why can't it just use the settings from the "Settings/Audio/Input" menu??
 
  • Like
Reactions: star-affinity
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.