Default send-from email address in Mail?

Discussion in 'macOS' started by ravenvii, Nov 6, 2007.

  1. ravenvii macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #1
    I have two email addresses set up with Mail. But I want one of them to be the default email address when I compose a new message. I often forget to change the email address and end up sending with an email address I didn't want to use.

    Mail 2.0 has this, but I can't seem to find it anywhere in Mail 3.0?
     
  2. fistful macrumors 6502a

    fistful

    Joined:
    Mar 29, 2004
    Location:
    Socan
    #2
    I think you just put the account you want to be default at the top of the preferences -> accounts. That's how it works in Mail 2, I assume it's the same for Mail 3.

    edit: nevermind, that wasn't it. That is one of the things I tried when I was trying to figure out how to change the default. I don't remember then changing it in the composing tab of the prefs but I must have.

    Try it though, might be how it's done in Mail 3.0.
     
  3. ravenvii thread starter macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #3
    No it isn't. Thanks though.

    Anyone?
     
  4. LMO macrumors member

    Joined:
    Jun 8, 2007
    #4
    Go to Mail, Preferences and click on Accounts. Set the Outgoing Mail Server to whatever account you want to use, and check "Use only this server."

    You'll only need to set this for the "other" account.
     
  5. ravenvii thread starter macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #5
    No, I don't want to *always* send from one email address. I only want it to be the default selected email address when I compose a new message. Otherwise, if I reply to a message, I do want it to default to the email address I received the message in, and I do want to have the option of choosing the email address I want to send from if I desire so.

    This is the behavior in Tiger. If Apple omitted this in Leopard, then that is sheer retardation.
     
  6. ravenvii thread starter macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #6
    Aha, I found it. To choose an account from which to send all messages, choose Mail > Preferences > Composing. Then choose an account from the “Send new mail from” pop-up menu.
     
  7. Europe calling macrumors regular

    Europe calling

    Joined:
    Jun 27, 2007
    Location:
    The Netherlands
    #7
    I found the solution!

    You have to arrange the accounts in the INBOX part of the sidebar in the main mail window.
    The top one will then be the default account from which you'll send mail from.

    Cheers:)
     
  8. ravenvii thread starter macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #8
    No. Look at my post above.
     
  9. Europe calling macrumors regular

    Europe calling

    Joined:
    Jun 27, 2007
    Location:
    The Netherlands
    #9
    The result is the same

    You' ll get the same results by reordering the inboxes in the sidebar. This way you can change it on the fly without having to go to account prefs.

    Anyway, it works in Leopard!
     
  10. Auctioneer macrumors newbie

    Joined:
    Dec 13, 2010
    Location:
    Wichita, KS
    #10
    Ravenvii - I finally figured out how to do this after numerous embarrassing emails sent from my personal account. A visual reminder doesnt work for me, I need to be 100% sure they were always sending from same email account regardless of where they were sent from, here is how you do it:

    Step 1 – Set default under preferences – composing – to send new messages from (select desired email). This will make all NEW emails send from that address.

    Step 2 – To change all reply emails to reply from same email regardless of where the message was sent from, go into preferences – accounts – and under each account change the email address to your desired email from, and change outgoing server to only send from desired email, need to check the box below. I have tested replying from various inboxes and it so far has always been from my correct email. Hope this helps, as I was horrified when I saw my college email in an outgoing email to a CEO. Lovely.
     
  11. Spikeefix macrumors newbie

    Joined:
    Nov 17, 2010
    #11
    Thanks, OP! What a timely post for me! I've had this issue for probably a year or so, but have really been missing the boat on these outgoing messages recently. This is exactly what I needed.

    You have saved our lives. We are eternally grateful! :D
     
  12. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #12
    This method does not produce the desired result in Mail 4.x in SL.
     

Share This Page